VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Anzahl der Übereinstimmungen in zwei Bereichen ermitteln

Gruppe

Matrix

Bereich

Matrixfunktion

Thema

Anzahl der Übereinstimmungen in zwei Bereichen ermitteln

Problem

Wie kann ich ermitteln, welche Werte in zwei Bereichen an gleicher Position erscheinen?

Lösung

Folgende Matrixformel: =SUMME((A1:A20=C1:C20)*(B1:B20=D1:D20))




StandardModule: Modul1

Sub SendMessage()
   MsgBox "Vorhandene Mails: " & GrapText
End Sub

Function GrapText() As Long
   Dim objOutlook As Object
   Dim objnSpace As Object
   Dim objFolder As Object
   Set objOutlook = CreateObject("Outlook.Application")
   Set objnSpace = objOutlook.GetNamespace("MAPI")
   Set objFolder = objnSpace.Folders("Persönliche Ordner").Folders("Posteingang")
   GrapText = objFolder.Items.Count
   Set objFolder = Nothing
   Set objnSpace = Nothing
   Set objOutlook = Nothing
End Function

    


Beiträge aus dem Excel-Forum zu den Themen Matrix und Matrixfunktion