Microsoft Excel

Herbers Excel/VBA-Archiv

WENN-Formel mit zwei Bedingungen in Matrixtabelle

Betrifft: WENN-Formel mit zwei Bedingungen in Matrixtabelle von: Werner Köster
Geschrieben am: 16.05.2008 10:16:00

Hallo zusammen,

ich möchte in einer Tabelle mit Hilfe einer Formel immer dann den Wert aus Spalte C darstellen, wenn die Werte aus Spalte A und B den Beschriftungen aus Spalte E und Zeile 1 gleichen.

Mein Lösungsansatz funktioniert leider nur so lange, wie die Name in der gleichen Zeile stehen und die Namen nur einmal vorkommen. In der letztendlich von mir verwendeten Datei befinden sich die Basiswerte (Spalte A-B-C) und die Matrixtabelle auf zwei verschiedenen Tabellenblättern (nur zur Info, sofern dies größere Auswirkungen auf die Formel hat.).

Kann mir jemand sagen, wie es richtig geht, damit in der Beispieldatei auch die "gelben Zellen" mit Werten gefüllt werden.

https://www.herber.de/bbs/user/52391.xls

Gruß
Werner

  

Betrifft: AW: WENN-Formel mit zwei Bedingungen in Matrixtabelle von: Uwe (:o)
Geschrieben am: 16.05.2008 10:50:48

Hi Werner,
schreibe das:
=SUMMENPRODUKT(N($A$2:$A$100=$E2)*N($B$2:$B$100=F$1)*($C$2:$C$100))
mal in F2 und kopiere es dann in die anderen Zellen. Sollte klappen!?

Gruß
Uwe
(:o)


  

Betrifft: AW: WENN-Formel mit zwei Bedingungen in Matrixtabelle von: Werner
Geschrieben am: 16.05.2008 15:43:09

Hallo Uwe,

könnte besser nicht klappen !!! ;-)

Vielen Dank

Gruß
Werner


 

Beiträge aus den Excel-Beispielen zum Thema "WENN-Formel mit zwei Bedingungen in Matrixtabelle"