Microsoft Excel

Herbers Excel/VBA-Archiv

Mehrere Wenn- Funktionen und Sverweise mit Finden


Betrifft: Mehrere Wenn- Funktionen und Sverweise mit Finden von: Jan
Geschrieben am: 29.08.2016 17:31:53

Liebe Leute ich bin verzweifelt,

folgende Formel finden nur teilweise ihr Ziel:

=WENN(FINDEN("NPK";AI2);SVERWEIS("NPK";Matrix!A:B;2;FALSCH);WENN(FINDEN("NPG";AI2);SVERWEIS("NPG"; Matrix!A:B;2;FALSCH);""))

die erste Prüfung wird gefunden und die Funktion führ alles richtig aus. Wenn die erste Wenn-Prüfung aber nicht greift, werden die anderen nicht angefangen sondern der Fehler #Wert geliefert.

Ich verstehe aber nicht warum? Wenn beide Wenn-Prüfungen negativ sind, müsste die Zelle leer ("") bleiben. Aber auch wenn die erste Prüfung negativ ist und die zweite positiv, wird #Wert ausgegeben. Dabei steht definit NPG als Teilstring in der Zelle.

Was mache ich falsch?

Vielen Dank für eure Hilfe.

LG

Jan

  

Betrifft: AW: Mehrere Wenn- Funktionen und Sverweise mit Finden von: SF
Geschrieben am: 29.08.2016 17:37:37

Hola,

bei einem Fehlerwert prüft die Formel nicht weiter.

=WENNFEHLER(WENNFEHLER(WENN(FINDEN("NPK";AI2);SVERWEIS("NPK";Matrix!A:B;2;FALSCH));WENN(FINDEN("NPG"; AI2);SVERWEIS("NPG";Matrix!A:B;2;FALSCH);""));"") 
Gruß,
steve1da


  

Betrifft: AW: Mehrere Wenn- Funktionen und Sverweise mit Finden von: Jan
Geschrieben am: 30.08.2016 08:47:31

Danke Steve!!! Funktioniert!!! Wieder was dazu gelernt


Beiträge aus den Excel-Beispielen zum Thema "Mehrere Wenn- Funktionen und Sverweise mit Finden"