Herbers Excel-Forum - das Archiv

wenn dann funktion

Bild

Betrifft: wenn dann funktion
von: wolfgang

Geschrieben am: 06.04.2005 07:54:13
folgendes problem: ich hab in einer tabelle die alle inventurnummern (von allen stockwerken ca 12000) und in einer anderen tabelle die inventurnummer von den einzelnen stockwerken (auch anlagen die keine inventarnr. zugeordnet haben).
ich möchte jetzt einen vergleich bzw kontrolle anstellen. ich kann aber jeweils immer nur ein stockwerk auf einmal kontrollieren. möchte aber alle 4 stockwerke auf einmal kontrollieren. dürfte einen formelfehler haben
=WENN(C2='[Vergleich_Bestand_Inventar.xls]Bestand mit INR'!$B:$E;"ja";"nein")
hingegen
=WENN(C2='[Vergleich_Bestand_Inventar.xls]Bestand mit INR'!$E:$E;"ja";"nein") ist falsch.
c2=(inventarnummer), im bestand imt inr B:E=(die 4 einzelnen stockwerke)
spielt das eine rolle im in der tabelle bestand mit inr in der a spalte auch die selben inventarnr. eingetragen sind wie in der spalte c2.
danke
Bild

Betrifft: korrigierte wenn dann funktion
von: wolfgang
Geschrieben am: 06.04.2005 07:57:32
WENN(C2='[Vergleich_Bestand_Inventar.xls]Bestand mit INR'!$B:$E;"ja";"nein") ist falsch
und RICHTIG IST/WÄRE
WENN(C2='[Vergleich_Bestand_Inventar.xls]Bestand mit INR'!$E:$E;"ja";"nein")
Bild

Betrifft: alle 4 Stockwerke...
von: IngoG
Geschrieben am: 06.04.2005 08:44:11
Hallo Wolfgang,
versuchs mal so:
=wenn(zählenwenn('[Vergleich_Bestand_Inventar.xls]Bestand mit INR'!$B:$E;c2)>0;"JA","NEIN")
Gruß Ingo
Bild

Betrifft: AW: alle 4 Stockwerke...
von: wolfgang

Geschrieben am: 06.04.2005 10:33:34
hallo ingo,
danke die formel hat funktioniert. erklär mir nur bitte (sollten mich meine kollegen fragen, wie ich auf die formel komme) was "zählenwenn" und größer null - sprich den sinn der formel - danke
apropos: zwischen "ja" und "nein" gehört kein beistrich sondern semikolon
nochmals vielen dank
wolfgang
Bild

Betrifft: AW: alle 4 Stockwerke...
von: IngoG

Geschrieben am: 06.04.2005 14:05:31
Hallo Wolfgang,
es wird einfach gezählt, wie häufig c2 in dem angegebenen Bereich vorkommt.
wenn der Wert mehr als 0 mal vorkommt ist er vorhanden, also wird "ja" zurückgegeben sonst "NEIN" ;-)
Gruß Ingo
 Bild
Excel-Beispiele zum Thema "wenn dann funktion"
Funktion ANZAHL2 ohne ausgeblendete Spalten Mit der Indirekt-Funktion auf geschlossene Arbeitsmappe zugreifen
Benutzerdefinierte SVERWEIS-Funktion über mehrere Bereiche Alle Prozeduren und Funktionen auflisten
In Funktionskategorie einordnen Ausgabe einer benutzerdefinierten Funktion in Matrixformel
Benutzerdefinierte Funktion durch Code erstellen und löschen Ermittlung von Entfernungen über benutzerdefinierte Funktion
Handhabung von Arrays in benutzerdefininierten Funktionen Arbeitsmappen-Titel über benutzerdefinierte Funktion