Live-Forum - Die aktuellen Beiträge
Anzeige
Archiv - Navigation
1096to1100
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Wenn-Dann-Funktion

Wenn-Dann-Funktion
Notzm
Hallo Experten...
ich hab eine Tabelle in der in der Spalte F in jeder Zelle eine 0 oder eine höhere Zahl eingetragen wird.
Die Funktion soll mir alle Zellen, in der keine 0 steht (und die leeren auch nicht), also nur Zellen in dieser Spalte, in denen eine Zahl größer 0 steht addieren.
Vielen Dank für eure Antwort :-)

11
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Wenn-Dann-Funktion
31.08.2009 13:17:37
Matthias5
Hallo,
 in jeder Zelle eine 0 oder eine höhere Zahl eingetragen wird.
Wenn die Zahlen alle größer oder gleich Null sind - wie du schreibst - dann reicht ja eine einfache Summe!
Falls auch negative Zahlen möglich sind: =Summewenn(F:F;">0")
Gruß,
Matthias
AW: Wenn-Dann-Funktion
31.08.2009 13:21:43
Notzm
Ja aber die Summe gibt mir ja nicht die Anzahl der Zellen wieder, wenn die Zahlen 2, 8, 12 oder wie auch immer sind?
Glaskugeldefekt
31.08.2009 13:27:46
Matthias5
Hi,
du schreibst:

Die Funktion soll mir alle Zellen, in der keine 0 steht ... , in denen eine Zahl größer 0 steht addieren.
Bei dieser Formulierung fällt es mir natürlich schwer zu erraten, dass du die Werte nicht addieren sondern zählen willst.
Mache aus Summewenn -> Zählenwenn: =Zählenwenn(F:F;">0")
Gruß,
Matthias
Anzeige
AW: Glaskugeldefekt
31.08.2009 13:33:34
Notzm
Ok....ich bin echter Anfänger...sorry
Also wenn ich das einfüg, dann zeigt er mir "0" an..kein PLan warum.....
Liegt es vielleicht an der Überschrift in der Spalte F oder warum?
Vielen Dank
Lade hier doch mal ein Beispiel hoch! oT
31.08.2009 13:45:42
Matthias5
AW: Lade hier doch mal ein Beispiel hoch! oT
31.08.2009 13:49:46
Notzm
OK....hier ein Beispiel (hab nur einen Teil rauskopiert und in Spalte A eingetragen....
https://www.herber.de/bbs/user/64129.xls
Dankeschön
AW: Lade hier doch mal ein Beispiel hoch! oT
31.08.2009 13:53:06
Matthias5
Da sehe ich kein Problem:
Tabelle1
 AB
1Bekannte Größen 
2   
3020
42 
51 
66 
712 
856 
90 
100 
110 
1213 
134 
147 
155 
162 
173 
181 
190 
200 
211 
2224 
2356 
2434 
2521 
2623 
2745 
2821 

verwendete Formeln
Zelle Formel
B3 =ZÄHLENWENN(A:A;">0")

Tabellendarstellung in Foren Version 4.8


Versuche mal Folgendes: Markiere in deiner Originaldatei Spalte F, gehe im Menü "Daten" auf "Text in Spalten" (keine Ahnung wo das bei XL2007 versteckt ist, das habe ich nicht) und dort sofort auf "fertigstellen". Geht es jetzt?
Anzeige
AW: Lade hier doch mal ein Beispiel hoch! oT
31.08.2009 13:59:37
Notzm
Geht immer noch nicht :-( Zeigt mir immer noch "0" an
Vielleicht bin ich auch einfach zu.....
Wenn dir noch was einfällt wär cool, ansonsten vielen vielen Dank für deine Mühen...
AW: Lade hier doch mal ein Beispiel hoch! oT
31.08.2009 14:22:26
David
Hallo.
Sind deine "Zahlen" auch wirklich Zahlen? Oder vielleicht nur als Text formatierte Zellen, in denen Zahlen stehen? Erkennt man meist an linksbündiger Ausrichtung oder der kleinen roten Ecke in den Zellen.
Hier mal der Effekt:
Tabelle1
 ABCD
10006
22  2 
310  10 
40  0 
58  8 
615  15 
70  0 
81  1 
90  0 
1011  11 

verwendete Formeln
Zelle Formel
B1 =ZÄHLENWENN(A1:A10;">0")
D1 =ZÄHLENWENN(C1:C10;">0")

Zahlenformate
Zelle Format Wert
A1 @0
A2 @2
A3 @10
A4 @0
A5 @8
A6 @15
A7 @0
A8 @1
A9 @0
A10 @11
Zellen mit Format Standard werden nicht dargestellt

Tabellendarstellung in Foren Version 4.11


Gruß
David
Anzeige
Lösung
31.08.2009 14:26:41
Notzm
Vielen Vielen Dank!!!!
Genauso klappt es ':-) Danke an euch beide
Gruß
AW: Lade hier doch mal ein Beispiel hoch! oT
31.08.2009 14:26:57
David
für den Fall auch hier gleich die Lösung:
Tabelle1
 ABCD
10006
2262 
310  10 
40  0 
58  8 
615  15 
70  0 
81  1 
90  0 
1011  11 

verwendete Formeln
Zelle Formel
B1 =ZÄHLENWENN(A1:A10;">0")
D1 =ZÄHLENWENN(C1:C10;">0")
B2 =SUMMENPRODUKT(--(--(A1:A10)>0))

Zahlenformate
Zelle Format Wert
A1 @0
C1 #.##00
A2 @2
C2 #.##02
A3 @10
C3 #.##010
A4 @0
C4 #.##00
A5 @8
C5 #.##08
A6 @15
C6 #.##015
A7 @0
C7 #.##00
A8 @1
C8 #.##01
A9 @0
C9 #.##00
A10 @11
C10 #.##011
Zellen mit Format Standard werden nicht dargestellt

Tabellendarstellung in Foren Version 4.11


Gruß
David
Anzeige

345 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige