Microsoft Excel

Herbers Excel/VBA-Archiv

verschachtelte Wenn Funktion mit Leerzelle

Betrifft: verschachtelte Wenn Funktion mit Leerzelle von: Frans
Geschrieben am: 04.03.2013 14:16:11

Ich habe folgendes Problem: Ich möchte einen einfachen Vokabeltrainer entwerfen. Ich habe in Spalte A die deutschen Vokabeln und in D die Fremdsprachen Ausdrücke. Spalte B ist die Eingabe vorgesehen und C sagt mir ob ich richtig oder falsch liege.Die entsprechende Formel, die ich hierfür fand/entwarf ist scheinbar trotz Google nicht korrekt:
=WENN(ISTLEER(B2);"";WENN(ISTNV(VERGLEICH(B2;D2;0));"falsch";"richtig"))

Kann mir jemand sagen, was hier falsch ist?
Danke

  

Betrifft: AW: verschachtelte Wenn Funktion mit Leerzelle von: Klaus M.vdT.
Geschrieben am: 04.03.2013 14:21:43

Hallo Franz,
deine Formel sieht unnötig kompliziert aus.
=WENN(ISTLEER(B2);"";B2=D2)
sollte eigentlich reichen.

Grüße,
Klaus M.vdT.


  

Betrifft: Schon lustig, die anderen AWn, Klaus! ;-) orT von: Luc:-?
Geschrieben am: 04.03.2013 20:53:03

Gruß Luc :-?


  

Betrifft: Ich würd mich ja ... von: Klaus M.vdT.
Geschrieben am: 05.03.2013 08:47:54

... über eine Antwort von Frans freuen, aber Rückmeldungen sind ja nicht mehr modern.

Grüße,
Klaus M.vdT.


  

Betrifft: Geiz+Ego-Courtesy=>Geil! ;-> Gruß owT von: Luc:-?
Geschrieben am: 08.03.2013 02:43:03

:-?


  

Betrifft: ? Den versteh ich jetzt nicht ... owT von: Klaus M.vdT.
Geschrieben am: 08.03.2013 08:08:13

.


  

Betrifft: Kurzerklärung für diese 'Mode'! Gruß owT von: Luc:-?
Geschrieben am: 08.03.2013 11:00:59

:-?


  

Betrifft: AW: verschachtelte Wenn Funktion mit Leerzelle von: Michael Kreitz
Geschrieben am: 04.03.2013 14:25:51

Hallo Frans,

hab die Formel nach deiner Beschreibung ausprobiert.
Funktioniert einwandfrei.
Was gibt deine Formel denn für einen Fehler zurück?

Gruß Michael


  

Betrifft: AW: verschachtelte Wenn Funktion mit Leerzelle von: Klaus M.vdT.
Geschrieben am: 04.03.2013 14:32:23


Hallo Michael,

die Formel ist - zumindest für einen Vokabeltrainer - völlig unbrauchbar!

Schreib mal in A2: "Hund", in D2 "dog"
in A3: "Katze", in D3 "cat"
in A4: "Unsinn", in D4 "caterpillar".
in C2:C3 die fragliche Formel.

Schreibst du jetzt in B2 das wort "caterpillar", dann meldet die Formel: "Ja, das ist ein Hund!". Und das ist natürlich Unsinn.

Grüße,
KLaus M.vdT.


  

Betrifft: AW: verschachtelte Wenn Funktion mit Leerzelle von: Matze Matthias
Geschrieben am: 04.03.2013 14:35:12

Die Formel =Vergleich(B2;D2;0) würde ein #NV liefern wenn B2 =""

=Wennfehler(vergleich(B2;D2;0),"")
Ab Version 2007 Wennfehler, macht hier ein "" aus dem Fehler

Matze


  

Betrifft: AW: verschachtelte Wenn Funktion mit Leerzelle von: Klaus M.vdT.
Geschrieben am: 04.03.2013 14:36:29

Hallo Matze,

WENNFEHLER hin oder her ist die gezeigte Formel für einen Vokabeltrainer ziemlich sinnbefreit.

Grüße,
Klaus M.vdT.


 

Beiträge aus den Excel-Beispielen zum Thema "verschachtelte Wenn Funktion mit Leerzelle"