Doppelte Wenn und Funktion

Bild

Betrifft: Doppelte Wenn und Funktion von: Pitti
Geschrieben am: 06.02.2005 15:26:18

Ich möchte 2 Bedingungen abfragen und weiß nicht wo ich die 2. wenn Funktion
einfügen muß damit es funktioniert.
etwa so sieht es aus

=WENN(UND(F13=WAHR;F15=WAHR);WERT(N15*(E14-C14));0)


WENN(UND(F13=FALSCH;F15=WAHR);WERT(M15*(E14-C14));0)

Evtl. könnte die 2. Abfrage auch nur F13 abfragen
wenn F13 wahr ist soll nichts passieren,nur wenn F15 wahr ist soll F13 abgefragt
werden und dann verzweigt werden(anderer Multiplikator).

Es sollte ohne VBA gehen, weil Ich davon fast keine Ahnung habe.

MfG. Pitti

Bild


Betrifft: Doppelte Wenn und Funktion von: MarioS
Geschrieben am: 06.02.2005 15:41:16

=WENN(UND(F15=WAHR;F13=WAHR);WERT(N15*(E14-C14));WENN(UND(F15=FALSCH;F13=WAHR);WERT(M15*(E14-C14));0))


Bild


Betrifft: AW: Doppelte Wenn und Funktion von: Pitti
Geschrieben am: 06.02.2005 19:22:12

Vielen Dank für die schnelle Hilfe Mario.
Die Syntax funktionierte sofort und nach kleinen Wertumstellungen war die Funktion perfekt.
Es ging auch in 1.Linie um die Syntax die ich noch nicht begriffen hatte.

MfG Pitti


Bild


Betrifft: AW: =(E14-C14)*INDIREKT("Z15S"&13+F15;0)*F13 von: FP
Geschrieben am: 06.02.2005 23:11:07

Hi Mario,

wäre auch noch eine Möglichkeit, aber ob Pit diese Syntax begreift ;-)

hier der Beweis:

Tabelle1
 ABCDEFG
1WAHRFALSCH1320127
2WAHRWAHR13201214
3FALSCHWAHR1320120
4FALSCHFALSCH1320120
Formeln der Tabelle
G1 : =(D1-C1)*INDIREKT("S"&5+B1;0)*A1
G2 : =(D2-C2)*INDIREKT("S"&5+B2;0)*A2
G3 : =(D3-C3)*INDIREKT("S"&5+B3;0)*A3
G4 : =(D4-C4)*INDIREKT("S"&5+B4;0)*A4
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Servus aus dem Salzkammergut
Franz


Bild


Betrifft: AW: =(E14-C14)*INDEX(M15:N15;F15+1)*F13 o.T. von: FP
Geschrieben am: 07.02.2005 00:42:13




 Bild

Beiträge aus den Excel-Beispielen zum Thema "Doppelte Wenn und Funktion"