Microsoft Excel

Herbers Excel/VBA-Archiv

WENN DANN oder WENN DANN | Herbers Excel-Forum


Betrifft: WENN DANN oder WENN DANN von: merten
Geschrieben am: 21.08.2012 18:59:30

Hallo zusammen,

ich möchte gern eine WENN DANN Abfrage bauen die sich ab einem bestimmten Zellwert einen festen Wert in eine Zelle schreibt.

...wenn A1 > 4 dann nimm 0,5

dass klappt natürlich ...=WENN(A1>4;0,5)"

Ich möchte aber gern noch folgendes hinzufügen.

Ist der Wert in A1 >= dann nimm 0,75

und hier habe ich meine Schwierigkeiten.

Kann mir jemand helfen wie ich beide Bedingungen in der Formel unter bekommen, ohne dass sie sich behindern?

Danke schon mal ;-)

  

Betrifft: AW: WENN DANN oder WENN DANN von: Matze,Matthias
Geschrieben am: 21.08.2012 19:12:49

Hi Merten,
In Zelle B1 =WENN(A1=4;0,75;WENN(A1>4;0,5))
so gewollt?
Matze


  

Betrifft: AW: WENN DANN oder WENN DANN von: merten
Geschrieben am: 21.08.2012 19:36:45

hallo Matze,

danke, aber es ist ein klein wenig anders.


In Zelle B1 =WENN(A1<4;0;WENN(A1>4;0,5);WENN(A1>=6;0,75))



So müsste es eigentlich sein.



  

Betrifft: AW: WENN DANN oder WENN DANN von: Hajo_Zi
Geschrieben am: 21.08.2012 19:13:11

großer gleicgh welchem Wert?


=WENN(A1>=10;0,75;WENN(A1>4;0,5;"keineAngabe"))

GrußformelHomepage


  

Betrifft: AW: WENN DANN oder WENN DANN von: merten
Geschrieben am: 21.08.2012 19:30:31

hallo Hajo,

vielen Dank für deine schnelle Antwort.

Ich verstehe leider deine Frage bzw. Formel nicht ("keine Angabe")

Habe mich vllt. nicht richtig ausgedrückt.



Der Wert in A1 kann jeden Wert zw. 0 und 24 einnehmen. Innerhalb bestimmter Grenzen sollen von diesem Wert Werte abgezogen werden.

Ist der Wert in A1 < 4 soll nichts abgezogen werden, ist der Wert in A1>=4 soll der 0,5 abgezogen werden, ist der Wert in A1 jedoch >=6 soll 0,75 abgezogen werden.



Hoffe, habe es jetzt etwas deutlicher gemacht ;-)

Danke schön.


  

Betrifft: AW: WENN DANN oder WENN DANN von: Hajo_Zi
Geschrieben am: 21.08.2012 19:32:51

das ist eine andere Aufgabe als im ersten Beitrag.
=Wenn(A1<4;0;wenn(A1>=6;0,75;0,5))

Gruß Hajo


  

Betrifft: AW: WENN DANN oder WENN DANN von: merten
Geschrieben am: 21.08.2012 19:39:58

danke, so sollte es sein, ich bekomme jedoch als Ergebnis FALSCH angezeigt


  

Betrifft: AW: WENN DANN oder WENN DANN von: Hajo_Zi
Geschrieben am: 21.08.2012 19:41:34

ich bekomme 0 angezeigt, was bestimmt daran ligt das ich eine andere Tabelle habe.

Tabelle1

 AB
1  0

verwendete Formeln
Zelle Formel Bereich
B1 =WENN(A1<4;0;WENN(A1>=6;0,75;0,5)) 

Tabellendarstellung in Foren Version 5.49



Gruß Hajo


  

Betrifft: AW: WENN DANN oder WENN DANN von: merten
Geschrieben am: 21.08.2012 19:46:06

bei mir wird in A1 der Wert 9,5 errechnet.

B1 müsste also 0,75 anzeigen, aber bekomme nur FALSCH angezeigt.

Hast du eine idee woran das liegen könnte?

gruß merten


  

Betrifft: AW: WENN DANN oder WENN DANN von: Hajo_Zi
Geschrieben am: 21.08.2012 19:49:27

Du mußt schon meine Formel benutzen.

Tabelle1

 AB
19,50,75

verwendete Formeln
Zelle Formel Bereich
B1 =WENN(A1<4;0;WENN(A1>=6;0,75;0,5)) 

Tabellendarstellung in Foren Version 5.49



Gruß Hajo


  

Betrifft: AW: WENN DANN oder WENN DANN von: merten
Geschrieben am: 21.08.2012 19:58:32

jetzt klappt es, vielen Dank für deine Mühe ;-)

gruß merten