Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema Image
BildScreenshot zu Image Image-Seite mit Beispielarbeitsmappe aufrufen

Summewenn mit UND-Kriterium | Herbers Excel-Forum


Betrifft: Summewenn mit UND-Kriterium von: Roland
Geschrieben am: 03.12.2009 16:17:33

Moin Ihr Spezialisten,

hab mal wieder ein Problem und finde einfach die Lösung nicht.

Ich möchte die Summe über die Spalte B erhalten, wenn der Wert in Spalte A in einer Art "Range" liegt, zb zwischen 50000 und 60000.
Versucht habe ich =summewenn(A:A;und(>=50000;<60000);B:B)

Da erhalte ich aber immer nur eine Fehlermeldung, dass ein Fehler in der Formel sei.

Wenn ich die Kriterien in der UND Anweisung in "" setze, kommt nur 0 (NULL) heraus.

Kann mir jemand helfen?
Gerne auch in VBA, da dieses eine VBA-Abfrage werden muss.

Danke für's Lesen!

Gruß
Roland

  

Betrifft: AW: Summewenn mit UND-Kriterium von: ransi
Geschrieben am: 03.12.2009 16:22:36

HAllo

Versuchs doch mal so

=summewenn(a.a;">=500000";b:b)-=summewenn(a:a;">=600000";b:b)
ransi


  

Betrifft: AW: Summewenn mit UND-Kriterium von: jockel
Geschrieben am: 03.12.2009 16:26:36

hi ransi, ich glaube das geht so nicht...

Tabelle2

 ABCD
1500011  1
2450002  5
3600003   
4750004   

verwendete Formeln
Zelle Formel
D1 =SUMMENPRODUKT((A1:A1000>50000)*(A1:A1000<60000)*(B1:B1000))
D2 =SUMMEWENN(A:A;">=50000";B:B)-SUMMEWENN(A:A;"<60000";B:B)

Tabellendarstellung in Foren Version 4.31





cu jörg eine rückmeldung wäre ganz reizend


  

Betrifft: AW: Summewenn mit UND-Kriterium von: ransi
Geschrieben am: 03.12.2009 16:46:41

HAllo Jockel

Tabelle2

 ABCDE
1500011 1 
2450002 1 
3600003   
4750004   
5     

Formeln der Tabelle
ZelleFormel
D1=SUMMENPRODUKT((A1:A1000>50000)*(A1:A1000<60000)*(B1:B1000))
D2=SUMMEWENN(A:A;">50000";B:B)-SUMMEWENN(A:A;">=60000";B:B)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Summier alle die >50000 und zieh davon alle ab die > 60000
Übrig bleiben die zwischen 50000 und 60000.
Von der Logik her müsste das klappen.

ransi


  

Betrifft: sorry... von: jockel
Geschrieben am: 03.12.2009 17:02:10

hi ransi, da hatte ich wohl was missverstanden... dein ursprünglicher eintrag (die formel) war aber wohl aus der "hüfte geschossen"... noh mal es tut mir leid... :-(

cu jörg


  

Betrifft: AW: Summewenn mit UND-Kriterium von: jockel
Geschrieben am: 03.12.2009 16:22:50

hi Roland, versuch mal:

=SUMMENPRODUKT((A1:A1000>50000)*(A1:A1000<60000)*(B1:B1000))



cu jörg eine rückmeldung wäre ganz reizend


  

Betrifft: AW: Summewenn mit UND-Kriterium von: Klaus-Dieter
Geschrieben am: 03.12.2009 16:25:07

Hallo Roland,

SummeWenn erlaubt nur eine Bedingung. Versuche es einmal Summenprodukt.



Viele Grüße Klaus-Dieter

Klaus-Dieter's Excel und VBA Seite
Online-Excel



  

Betrifft: Antwort gefunden? von: Roland
Geschrieben am: 03.12.2009 16:28:12

Ich glaube mit SUMMEPRODUKT klappt das, kann das sein?

=SUMMENPRODUKT((A:A>=50000)*(A:A<60000)*B:B)

Bring zumindest das richtige Ergebnis, auch wenn ich nicht begreife, was da abgeht*grübel


  

Betrifft: AW: Antwort gefunden? von: jockel
Geschrieben am: 03.12.2009 16:32:15

hi Roland, das kann sein, wenn du Xl2007 benutzt... aber so ähnlich kamen ja auch die vorschläge hier

cu jörg


  

Betrifft: Boah danke für Antworten von: Roland
Geschrieben am: 03.12.2009 16:30:27

Mensch Jungs, seid Ihr flott!

Danke für die Tipps.
Kann mir jemand bitte erklären, wieso das mit SUMMENPRODUKT funktioniert?


  

Betrifft: das kann man googeln... von: jockel
Geschrieben am: 03.12.2009 16:36:54

hi Roland... schau mal hier: http://tinyurl.com/yb9u3sa gleich der erste eintrag ist interessant für dich

cu jörg


  

Betrifft: das kann man googeln... Stimmt, danke! owT von: Roland
Geschrieben am: 03.12.2009 17:04:40

.


Beiträge aus den Excel-Beispielen zum Thema "Summewenn mit UND-Kriterium"