wenn und Funktion mit Maximalwert

Bild

Betrifft: wenn und Funktion mit Maximalwert
von: Schmitz
Geschrieben am: 29.04.2015 14:48:41

Hallo zusammen, ich habe folgendes Problem:
ich habe einen Wert "Fahrtkosten"(D17), die aus einem Wert "Gesamtbudget"(F8) bezahlt werden. Vorrangig wird hier jedoch ein anderer Wert "Leistung"(D23) bezahlt.
Ich suche nun die Formel (in D26), die mir folgenden Wert berechnet:
Wenn Fahrtkosten entstehen, und aus dem Gesamtbudget noch Leistungen frei sind, zeige hier die Höhe an, allerdings maximal bis zur Höhe der Fahrtkosten.
Gebastelt habe ich mir jetzt:
=WENN(UND(D17>0;UND(F8-D23>0));D17 ... und hänge....
Herzlichen Dank für Eure Hilfe!

Bild

Betrifft: =D17*(F8-D23>0) [owT]
von: EtoPHG
Geschrieben am: 29.04.2015 14:59:13


Bild

Betrifft: AW: =D17*(F8-D23>0) [owT]
von: Schmitz
Geschrieben am: 29.04.2015 15:07:21
Vielen Dank für die schnelle Antwort, EtoPHG; so einfach kann das sein...?
Allerdings spuckt er mir dann einen Wert aus, der gemeinsam mit den Fahrtkosten das Gesamtbudget übersteigt (aktuell Gesamtbudget 1.289,00; Leistung 1.150,25 und Fahrtkosten 562,50 - die werden auch übernommen, und so dass Gesamtbudget gesprengt)

Bild

Betrifft: AW: =D17*(F8-D23>0) [owT]
von: Herbert Grom
Geschrieben am: 29.04.2015 16:09:19
Hallo Schmitz,
bei mir hat dies Formel funktioniert. Probiers mal:

=WENN(D17<=0;0;WENN(F8-D23>D17;D17;WENN(F8-D23<0;0;F8-D23)))
Servus

Bild

Betrifft: Kürzer mit MEDIAN
von: lupo1
Geschrieben am: 29.04.2015 16:20:47
=WENN(D17<=0;0;WENN(F8-D23>D17;D17;WENN(F8-D23<0;0;F8-D23))) wird zu
=(D17>0)*MEDIAN(;F8-D23;D17) (ungetestet und den restlichen Thread nicht verfolgt)

Bild

Betrifft: AW: Kürzer mit MEDIAN
von: Herbert Grom
Geschrieben am: 29.04.2015 16:36:22
Wow, geile Funktion "MEDIAN". Noch nie etwas gehört davon.
Warum bleibt "ZAHL1" frei?
Servus


Bild

Betrifft: Das gibt es doch häufiger ...
von: lupo1
Geschrieben am: 29.04.2015 19:07:25
=VERGLEICH(LookUp;Vektor;) hat eine Null bzw. FALSCH hinten, die nicht geschrieben werden muss. Das Semikolon wird aber benötigt!
=VERGLEICH(LookUp;Vektor) hingegen hat als nicht obligatorisch aufzuführenden Default-Wert des 3. Arguments eine 1 oder WAHR.

Bild

Betrifft: AW: Das gibt es doch häufiger ...
von: Daniel
Geschrieben am: 29.04.2015 21:31:54
Hi
wenn das Semikolon nach dem 2. Parameter fehlt, dann wird der 3. Parameter nicht angegeben.
In diesem Fall setzt Excel dann, wenn der Parameter optional ist, den Default-Wert ein und das ist für die Funktion Vergleich der Wert 1
wird das Semikolon nach dem 2. Parameter gesetzt, aber kein Wert dahinter, so wird der 3. Parameter angegeben, aber als Leerwert (so wie ein Verweis auf eine Leerzelle).
Einen Leerwert interpretiert Excel jedoch als 0, wenn es eigentlich eine Zahl erwartet.
Gruß Daniel

Bild

Betrifft: AW: Das gibt es doch häufiger ...
von: Herbert Grom
Geschrieben am: 30.04.2015 08:38:43
Sicher gibt es das häufiger. Ich habe aber deshalb hier gefragt, da in der Excel-Hilfe zu MEDIAN folgendes steht:
Syntax
MEDIAN(Zahl1;[Zahl2];...)
Die Syntax der Funktion MEDIAN weist die folgenden Argument auf:
Zahl1;Zahl2;... Zahl1 ist erforderlich, die nachfolgenden Zahlen sind optional. 1 bis 255 Zahlen, deren Median Sie berechnen möchten.
Und lupo1 lässt aber genau diese "Zahl1" leer. Deshalb habe ich mich gewundert. Also ist die MS Hilfe mal wieder für die Tonne, denn lupo1 hat sie Lügen gestraft!
Servus

Bild

Betrifft: lupo straft MS keine Lügen ...
von: lupo1
Geschrieben am: 30.04.2015 08:59:00
Wie gesagt: Ob 0; oder ; geschrieben wird, ist in vielen (nicht allen!) Fällen egal! Also ist auch ; nicht leer. Beispiel:
B1: =A1-WAHL(REST(A1;7)+1;1;2;;;;;) gibt den Tag oder vorangehenden Werktag zurück (ohne Feiertagsbetrachtung; dafür nimmt man =ARBEITSTAG().

Bild

Betrifft: Korrektur: ob ;0 oder ; ist oft egal -owT
von: lupo1
Geschrieben am: 30.04.2015 09:00:39


Bild

Betrifft: ...und noch kürzer und verständlicher...
von: EtoPHG
Geschrieben am: 29.04.2015 17:45:17
mit Minimun,

=MIN(D17*(F8-D23>0);F8-D23)

Deine Bedingung, dass das Gesamtbudget nicht überschritten werden darf, hast du in deiner Anfrag schlicht nicht erwähnt.
Gruess Hansueli

Bild

Betrifft: AW: ...und noch kürzer und verständlicher...
von: Herbert Grom
Geschrieben am: 29.04.2015 18:25:16
Hallo Hansueli,
da bin ich wieder einmal baff! Was man mit der MIN-Funktion alles machen kann. Also da müssen wir in Dresden noch einmal darüber reden, OK?
Servus und bis in 2 Wochen!

Bild

Betrifft: AW: ...und noch kürzer und verständlicher...
von: Schmitz
Geschrieben am: 30.04.2015 08:26:35
Hallo an alle Helfer,
vielen Dank für das Teilen Eures Wissens; Ihr habt mir viele Stunden ohne Erfolgserlebnis erspart!

Bild

Betrifft: AW: ...und noch kürzer und verständlicher...
von: Herbert Grom
Geschrieben am: 30.04.2015 08:53:11
Hallo ??? Hat "Schmitz" auch einen Vornamen?
gerne geschehen!
Servus

 Bild

Beiträge aus den Excel-Beispielen zum Thema "wenn und Funktion mit Maximalwert"