Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Wenn Dann für bestimmte Bereiche

Wenn Dann für bestimmte Bereiche
09.09.2008 11:32:00
Jan
Hallo,
erstmal möchte ich hallo sagen in diesem tollen Forum und gleich eine Frage zu einer Formel hinterherjagen, an der ich verweifel.
Ich soll für einen Kollegen eine Wenn-Dann Formel erstellen.
Also in etwa sieht es so aus.
In A1 - A30 stehen verschiedene Werte (von 17.500 - 37.000.000).
Diesen Werten folgen bestimmte Zahlen (z.B. 17.500 = 7, oder 80.000 = 32).
Einige Werte sind allerdings zusammengefasst, also von 100.001 - 199.999 = 41 und von 200.000 - 299.999 = 42 etc.....
Hieraus soll nun eine Formel erstellt werden, das Automatisch hinter der Zahl in A1, also in B1, in diesem Falle die erscheint.
Wenn z.B. in A2 dann 225.000 steht, sollte in B2 automatisch die 42 erscheinen.
Ich hoffe ich habe das einigermaßen verständlich geschrieben.
Vielleicht kann mir hier ja jemand helfen.

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Wenn Dann für bestimmte Bereiche
09.09.2008 11:55:00
Jan
Hallo,
danke für das schnelle Feedback. Aber wenn ich jetzt als Zahl 225.000 eingebe, sollter er eigentlich auch die 42 eintragen, da ja alle Zahlen zwischen 200.000 und 299.999 die Zahl 42 zugeordnet bekommen sollen.
AW: Wenn Dann für bestimmte Bereiche
09.09.2008 11:59:51
Mac4
HI Jan,
macht er doch auch!?
Marc
AW: Wenn Dann für bestimmte Bereiche
09.09.2008 13:13:55
Jan
Stimmt, macht er auch, habe da eben was falsches eingegeben.
Hat super geklappt, habe mit dem Sverweis noch nie gearbeitet.......Super Tip.
Da werde ich mich mal ein wenig mehr mit beschäftigen.
Vielen Dank
Anzeige
AW: Wenn Dann für bestimmte Bereiche
09.09.2008 11:53:00
Andi
Hi,
probier mal dies:
=WENN(A1<=100000;ABRUNDEN(A1/2500;0);ABRUNDEN(A1/100000;0)+40)
Schönen Gruß,
Andi
AW: Wenn Dann für bestimmte Bereiche
09.09.2008 12:08:00
David
Hallo Jan,
die von dir verwendete Datentabelle ist grundsätzlich problematisch, da ein Intervallvon 200000-299999 für Excel erst einmal Text ist. Wenn die anderen dann normale Zahlen sind, vermischt du hier Text und Zahlen und da wird's meist kompliziert.
Die einfache Variante wäre, in der Datentabelle IMMER mit Ober- und Untergrenze zu arbeiten. Dann könnte man eine einfache SVERWEIS-Formel nehmen.
Wenn es aber partout nicht anders geht, kannst du folgende Formel verwenden:

Tabellenblattname: Tabelle1
 

A

B

C

D

1

17500

7

200000

42

2

80000

32

 

 

3

199999

40

 

 

4

200000-299999

42

 

 



Benutzte Formeln:
D1: {=INDEX(B1:B4;MIN(WENN(WENN(ISTFEHLER(SUCHEN("-";A1:A4));$C$1 $C$1 (Achtung Matrixformel: {} nicht eingeben, sondern Formel mit STRG-SHIFT-ENTER abschließen)
Rückmeldung wäre nett.
Gruß
David

Anzeige
AW: Wenn Dann für bestimmte Bereiche
09.09.2008 13:15:00
Jan
Danke für die Info.
Aber mit dem Sverweis hat es nun auch super geklappt. Habe mit dem aber noch keine Erfahrungen gehabt. Werde mich mit dem mal näher beschäftigen.
Trotzdem danke für deine Hilfe und den Tip.
Gruß
Jan

307 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige