Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema RefEdit
BildScreenshot zu RefEdit RefEdit-Seite mit Beispielarbeitsmappe aufrufen

Wert in einem Bereich finden | Herbers Excel-Forum


Betrifft: Wert in einem Bereich finden von: Alex
Geschrieben am: 24.11.2009 16:07:18

Hallo zusammen,

ich möchte folgende Bedingung z.B. mit der WENN DANN Funktion ableiten.
Ich habe eine Spalte mit Zahlen, von 1-100 mehrfach vorkommend. Diese Spalte ist mein Kriterium.
Jetzt soll die Formel prüfen, ob der Wert in der Spalte ZWISCHEN 20 und 30 sich befindet und dann einen Wert xy ausgeben.
Diese Berechnung des Wertes in einem Bereich bekomme ich nicht hin. Hat jemand eine Idee.??

Danke schon mal...
Alex

  

Betrifft: AW: Wert in einem Bereich finden von: werni
Geschrieben am: 24.11.2009 16:20:00

Hi Alex

Mit Summenprodukt (Angenommen die Zahlen sind in Spalte G)

=SUMMENPRODUKT((G$2:G$2000<=40)*(G$2:G$2000>=30)*(G$2:G$2000

Gruss Werner


  

Betrifft: AW: Wert in einem Bereich finden von: Thomas R.
Geschrieben am: 24.11.2009 16:27:20

Hallo,

geht das nicht auch über eine Wenn(UND-Formel?

Also =WENN(UND(A1<30;A1>20);"WERTXY";"")

MfG, Tom


  

Betrifft: AW: Wert in einem Bereich finden von: werni
Geschrieben am: 24.11.2009 16:44:35

Hi Tom

Kannst du auch haben.

=SUMMEWENN(G:G;">=30";G:G)-(SUMMEWENN(G:G;">40";G:G))

Gruss Werner


Beiträge aus den Excel-Beispielen zum Thema "Wert in einem Bereich finden"