Microsoft Excel

Herbers Excel/VBA-Archiv

Formel über VBA in Range.

Betrifft: Formel über VBA in Range. von: Tom
Geschrieben am: 13.08.2008 11:41:37

Hi,
ich Versuch eine Summenformel

=SUMME(A3:A29)


verzweifelt über VBA dynamisch einzutragen.

Die Summe muss von A bis J eingetragen werden. Jedesmal mit dem entpsrechenden Buchstaben nicht immer mit A.

Hab das so versucht:

For k = 2 To 10
        
            'Range(Cells(k, 29), Cells(k, 29)).Formula = Summe=(cells(k,3),cells(k,30))
            Range(Cells(k, 29), Cells(k, 29)).FormulaR1C1 = "SUMME(B" & k & ":J" & k & ")"
            Next k


aber beides funktioniert nicht.

  

Betrifft: AW: Formel über VBA in Range. von: Rudi Maintaire
Geschrieben am: 13.08.2008 11:47:55

Hallo,
Range("A29:J29").FormulaR1C1="=Sum(R3C:R[-1]C)"

Gruß
Rudi


  

Betrifft: AW: Formel über VBA in Range von: Erich G.
Geschrieben am: 13.08.2008 12:21:32

Hallo Tom,
probier mal

Range("A29:J29").FormulaLocal = "=SUMME(A3:A29)"


Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: Korrektur von: Erich G.
Geschrieben am: 13.08.2008 12:24:36

Hi,
mein Vorschlag ergäbbe einen Zirkelbezug. Besser wohl

Range("A29:J29").FormulaLocal = "=SUMME(A3:A28)"



Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


 

Beiträge aus den Excel-Beispielen zum Thema "Formel über VBA in Range."