Microsoft Excel

Herbers Excel/VBA-Archiv

Spalten nach Wert durchsuchen, Zeile kopieren

Betrifft: Spalten nach Wert durchsuchen, Zeile kopieren von: P.M.
Geschrieben am: 30.09.2014 11:12:17

Hallo,

ich habe zwei Sheets, "Data" und "Sorted".
"Data" enthält mehrere Spalten, wobei Spalte A eine ID von 1 bis 4 enthält. Die IDs sind mehrfach vergeben.

In Sheet "Sorted" möchte ich die Daten gruppieren. Spalte A soll alle Wert1 der ID=1 auflisten, Spalte B soll Wert2 der ID=1 auflisten. Spalte C = Wert1 (ID=2), Spalte D = Wert2 (ID=2)... usw.

Im angehängten File habe ich das mal per Hand gemacht.
https://www.herber.de/bbs/user/92901.xlsx

Die Daten müssen nicht nach Größe, o.ä. sortiert werden.

Wie kann ich das automatisieren? Ich habe in Erinnerung, dass das irgendwie mit der Array und Index-Funktion geht, bekomme es aber nicht mehr hin...

Danke schön!

  

Betrifft: INDEX() von KKLEINSTE() und REST() ... von: neopa C (paneo)
Geschrieben am: 30.09.2014 15:58:26

Hallo,

... mit folgender MATRIX-Formel. die ziehend nach rechts und unten zu kopieren ist.

Sorted

 ABCDE
1ID=1 Wert1ID=1 Wert2ID=2 Wert1ID=2 Wert2ID=3 Wert1
20,1a0,9bc0,3
30,7ab0,2c0,7
40,4a0,4ca 
5     

Formeln der Tabelle
ZelleFormel
A2{=WENNFEHLER(INDEX(Data!$B:$C;KKLEINSTE(WENN(Data!$A$1:$A$99=TEIL(A$1;4;2)+0;ZEILE(A$1:A$99)); ZEILE(A1)); 2-REST(SPALTE(A1); 2)); "")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Data

 ABC
1IDWert1Wert2
210,1a
310,7ab
420,9bc
530,3abc
640,5bc
710,4a
820,2c
940,8ba
1030,7ab
1120,4ca
12   


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


 

Beiträge aus den Excel-Beispielen zum Thema "Spalten nach Wert durchsuchen, Zeile kopieren "