Microsoft Excel

Herbers Excel/VBA-Archiv

Suchen eines Datumswertes

Betrifft: Suchen eines Datumswertes von: Gorb
Geschrieben am: 24.11.2012 14:02:56

Hi @all

ich habe folgendes Problem an dem ich langsam Verzweifel

Ich habe zwei Spalten B und C in dehnen Datumswerte von stehen.
Beispiel
____B_________________C_____
07.01.2013________10.01.2013
15.01.2013________17.01.2013
21.01.2013________25.01.2013
usw.

In Zelle A1 trage ich ein Datum ein, welches ich in Spalte B suche, um dann das rechts daneben stehende Datum in Spalte C in Zelle A2 auszugeben.

Beispiel
Eingabe in A1 xx-07.01.2013 Ergebnis in A2 = 10.01.2013
Eingabe in A1 08-15.01.2013 Ergebnis in A2 = 17.01.2013
Eingabe in A1 16-21.01.2013 Ergebnis in A2 = 15.01.2013
usw

Kennt jemand eine Excel Formel, welches das Abbildet ohne das ich verschachtelte WENN Funktionen benutzen muss, mit einer WENN Prüfung pro KW ala A2=WENN(A1<=B1);C1;WENN(A1<=B2)C2)....

  

Betrifft: AW: Suchen eines Datumswertes von: Hajo_Zi
Geschrieben am: 24.11.2012 14:14:15

benutze Sverweis()
GrußformelHomepage


  

Betrifft: AW: Suchen eines Datumswertes von: Peter Kloßek
Geschrieben am: 25.11.2012 17:28:12

Hallo,

bitte benutze die folgende Formel in Zelle "A2":

=SVERWEIS(WERT(RECHTS(A1;10));B1:C3;2;FALSCH)

Das Datum in Zelle a1 musst Du stets mit "TT.MM.JJJJ" eingeben, sonst funktioniert es leider nicht.

M.f.G.
Peter Kloßek


 

Beiträge aus den Excel-Beispielen zum Thema "Suchen eines Datumswertes"