Live-Forum - Die aktuellen Beiträge
Anzeige
Archiv - Navigation
1296to1300
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zeichen Suchen und Text ausgeben

Zeichen Suchen und Text ausgeben
30.01.2013 14:18:17
Benjamin
Hallo,
ich habe folgendes Problem.
In Spalte A stehe Nummer die mit 2 Buchstaben zu beginn (Bsp. A1=AB123456).
Ich möchte nun nur mit der Nummer der Spalte A (123456) in Spalte B suchen und dann einen zugehörigen Wert aus Spalte Z in Spalte C1 einfügen.
Ich wäre für Tipps sehr dankbar.

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Zeichen Suchen und Text ausgeben
30.01.2013 14:26:13
UweD
Hallo
so z.B.
Tabelle1
 ABCDE
1AB123456N_A  123456N_A
2CD234567N_B  234567N_B
3EF456789N_C  456789N_C

verwendete Formeln
Zelle Formel Bereich
B1 =SVERWEIS(--TEIL(A1;3;99);D:E;2;0) 

Tabellendarstellung in Foren Version 5.49


das -- macht eine Zahl aus dem Text
Gruß UweD

Anzeige
AW: Zeichen Suchen und Text ausgeben
30.01.2013 15:01:59
Benjamin
Hallo Uwe,
danke für die schnelle Antwort.
Es hat mir auch schon ein bisschen weiter geholfen.
Ich bin leider noch nicht ganz am Ziel.
Bei mir wird jedes Mal nur #Wert! aus und für die gefundenen #NV!
Kann dies evtl. daran Liegen, dass der Text meist so aussieht : AB123456test

Ja, das hättest du sagen müssen! :-(
30.01.2013 15:07:36
Luc:-?
Luc :-?

AW: Zeichen Suchen und Text ausgeben
30.01.2013 15:36:01
UweD
Hallo nochmal
Sind die Ziffern denn immer 6-stellig oder auch unterschiedlich?
Wenn immer gleich, dann die 99 in der Formel durch 6 ersetzen
Gruß UweD

AW: Zeichen Suchen und Text ausgeben
30.01.2013 15:50:01
Benjamin
Die hat immer eine bestimmte Anzahl.
Habe das auch schon versucht, aber leider funktioniert das nicht.
Könnte es daran liegen, dass die Spalte in der gesucht wird wesentlich länger ist als die zu Suchende?
Die Formel für B1 sieht wie folgt aus
=SVERWEIS(--TEIL(A1;3;9);D:E;2;0)
wofür stehen denn die letzten beiden Bereiche?

Anzeige
Gegenvorschlag: mach doch mal eine Musterdatei
30.01.2013 16:05:59
UweD
.. mit Originaldaten
SVERWEIS(--TEIL(A1;3;9);D:E;2;0)
-- macht aus dem Text eine Zahl
Teil() nimmt den Inhalt von A1 ab der Stelle 3 bis 11 [3+9 minus 1)
D:E;2 bezogen auf mein Beispiel, wird der gesuchte Wert in Spalte D gesucht und aus der 2. Spalte [also E] zurückgegeben
;0 sagt aus, das die Werte nicht sortiert vorliegen müssen
Gruß UweD

SVERWEIS in C mit Zahl/Ziffern aus A auf B:Z
30.01.2013 14:29:27
Luc:-?
Hallo Benjamin;
Fallunterscheidung:
1. B enthält Textzahl
C1: =SVERWEIS(RECHTS(A1;LÄNGE(A1)-2);B:Z;25;0)
2. B enthält echte Zahl
C1: =SVERWEIS(--RECHTS(A1;LÄNGE(A1)-2);B:Z;25;0)
Gruß Luc :-?
Anzeige

315 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige