Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Ein Werteraum vergleichen und Punkte ausgeben

Ein Werteraum vergleichen und Punkte ausgeben
30.01.2013 15:06:32
David
Hallo, ich habe folgende Aufstellung:
Spalte 1: Punktwert; Spalte 2: untere Grenze; Spalte 3: obere Grenze
1 0 10
2 10 20
3 20 30
4 30 40
5 40 50
6 50 60
7 60 70
8 70 80
9 90 100
10 100 unendlich
In einer anderen Zelle habe ich ein Resultat z.B. 46. Mittels einem Array möchte ich nun, dass es diese 46 in der Liste sucht. Das heisst der Wert >= unterer Wert & Wert Mit einer normalen Formel ist es zwar machbar, aber es hat extrem viele Argumente. Irgend eine Idee, wie man das mittels einem Array berechnen könnte?

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Ein Werteraum vergleichen und Punkte ausgeben
30.01.2013 15:44:04
Rudi
Hallo,
ABCDEF
11010 465
221020
332030
443040
554050
665060
776070
887080
9990100
10#100unendlich

ZelleFormel
F1=INDEX(A1:A10;VERGLEICH(E1;B1:B10))

Gruß
Rudi

Anzeige
AW: Ein Werteraum vergleichen und Punkte ausgeben
30.01.2013 17:19:12
David
Herzlichen Dank für die Antwort. Leider geht diese Lösung nur bei meinem (schlecht) konstruierten Beispiel. Reale Zahlen wären z.B.
	A	B	C	D	E	F	G
1	2	10000	50000		Wert1	265629
2	4	50000	100000		Wert2	81928.5
3	6	100000	150000		Wert3	33311.6
4	8	150000	200000		Wert4	3066.2
5	10	200000	¥				
Die Werte 1 bis 4 müssten dabei gesucht werden und die dazupassende Punktzahl in Spalte A als Resultat ausgegeben werden.
Gruss
David

AW: Ein Werteraum vergleichen und Punkte ausgeben
30.01.2013 17:55:16
David
So, jetzt habe ich glaube ich eine Lösung gefunden: (für Resultat von F1)
=WENN(F1>=B1;SVERWEIS(F1;B1:D5;3;WAHR);0)
Zuerst schauen, ob der Wert überhaupt definiert ist, also überhaupt im Range liegt, dann einen simplen sverweis, aber man muss natürlich die Spalte A in die Spalte D kopieren, da der serverweis die erste Spalte durchsucht und der Wert einer späteren Spalte (hier 3) ausgibt.
Anzeige

323 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige