Microsoft Excel

Herbers Excel/VBA-Archiv

Zeilen nach Zahlenwert farblich einfärben

Betrifft: Zeilen nach Zahlenwert farblich einfärben von: reinhardt springer
Geschrieben am: 21.11.2012 12:59:56

Hallo.

Ich habe wöchentlich eine ca.400 Zeilen große Liste zu bearbeiten, die in Spalte D
Text u. Nummern hat.
Zur Bearbeitung ist eine abwechselnde farbliche Kennzeichnung z.B. grau/weiß erforderlich.
Soll heißen: Bei wechselndem Zahlenwert soll automatisch grau/weiß eingefärbt werden.
Ich brech mir einen ab, hierfür eine Art Schleife oder so zu schreiben.
Kann mir bitte jemand helfen?

Gruß Reinhardt

BO. 1114100 (Grau)
BO. 1114100 (Grau)
BO. 1114500 (weiß)
BO. 1114210 (Grau)
BO. 1114210 (Grau)
BO. 1114210 (Grau)
BO. 1114210 (Grau)
BO. 1114210 (Grau)
BO. 1114210 (Grau)
BO. 1114210 (Grau)
BO. 1114210 (Grau)
BO. 1114210 (Grau)
BO. 1114230 (weiß)
BO. 1114230 (weiß)
BO. 1114230 (weiß)
BO. 1114230 (weiß)
BO. 1114210 (Grau)
BO. 1114600 (weiß)

  

Betrifft: AW: Zeilen nach Zahlenwert farblich einfärben von: Rudi Maintaire
Geschrieben am: 21.11.2012 13:18:01

Hallo,
per bed. Formatierung.

AB
1xxxx
2BO. 11141001
3BO. 11141001
4BO. 11145002
5BO. 11142103
6BO. 11142103
7BO. 11142103
8BO. 11142103
9BO. 11142103
10BO. 11142103
11BO. 11142103
12BO. 11142103
13BO. 11142103
14BO. 11142304
15BO. 11142304
16BO. 11142304
17BO. 11142304
18BO. 11142105
19BO. 11146006

ZelleFormel
B2=WENN(A2=A1;B1;B1+1)

Zellebedingte Formatierung...Format
A21: =REST(B2;2)=0abc


Gruß
Rudi


  

Betrifft: Isses so recht? von: Marc
Geschrieben am: 21.11.2012 13:22:46

Hallo!
Bestimmt kann man die Formel auch in die bedingte Formatierung mit einbauen, aber bei Level "Excel gut" weißt du ja, wie´s geht....

https://www.herber.de/bbs/user/82718.xls

Gruß, MCO


  

Betrifft: Das ist super... Dankeschön.. o.T. von: reinhardt springer
Geschrieben am: 21.11.2012 13:46:03

o.T.


 

Beiträge aus den Excel-Beispielen zum Thema "Zeilen nach Zahlenwert farblich einfärben"