Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Summe Spaltenwerte nach Kriterien in Nachbarspalte

Summe Spaltenwerte nach Kriterien in Nachbarspalte
06.01.2013 13:14:30
Arno
Hallo liebe Excel-Gemeinde, ich hoffe, ich finde hier die Lösung für mein Problem.
Im Bereich A4:A369 habe ich alle 365 Daten ab 01.01. 2013 (Zellen als Datum formatiert) , in C Verbrauchswerte. In einer zweiten Tab, gleiches Blatt, die Monate in einer Zeile. Darunter will ich die Tages-Durchschnittsverbräuche je Monat anzeigen lassen.
Als Ausgangswerte werden zunächst die Monatsverbräuche errechnet
{=SUMME(WENN(MONAT($A$4:$A$369)=1;$C$4:$C$369;0))}.
Jetzt soll der momentane Monatsverbrauch aber nur durch die Anzahl der tatsächlichen Tagesverbräuche des Monats errechnet werden. Ich habe es schon mit ZÄHLENWENNS probiert, es klappt einfach nicht.
Wäre dankbar für Hilfe, alle gefundenen Hinweise waren leider nicht erfolgreich.

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Summe Spaltenwerte nach Kriterien in Nachbarspalte
06.01.2013 13:36:48
hary
Hallo Arno
Versteh ich nicht.
"Monatsverbrauch aber nur durch die Anzahl der tatsächlichen Tagesverbräuche des Monats errechnet "
vlt.hilft Dir das weiter.
Tabelle1
 ABCDEF
101.01.2013         
202.01.2013  10  JanuarFebruar
303.01.2013      3516
404.01.2013  2  32
505.01.2013         
606.01.2013  23     
707.01.2013         
808.02.2013         
909.02.2013  12     
1010.02.2013         
1111.02.2013  4     
12           

verwendete Formeln
Zelle Formel Bereich
E3 =SUMMENPRODUKT((MONAT($A$1:$A$15)=MONAT(E$2&1))*($C$1:$C$15<>"")*($C$1:$C$15)) 
F3 =SUMMENPRODUKT((MONAT($A$1:$A$15)=MONAT(F$2&1))*($C$1:$C$15<>"")*($C$1:$C$15)) 
E4 =SUMMENPRODUKT((MONAT($A$1:$A$15)=MONAT(E$2&1))*($C$1:$C$15<>"")) 
F4 =SUMMENPRODUKT((MONAT($A$1:$A$15)=MONAT(F$2&1))*($C$1:$C$15<>"")) 

Tabellendarstellung in Foren Version 5.30


gruss hary

Anzeige
AW: wer lesen kann...
06.01.2013 13:39:11
hary
Hallo
...ist im Vorteil.;-))
Tabelle1
 ABCDEF
101.01.2013         
202.01.2013  10  JanuarFebruar
303.01.2013      3516
404.01.2013  2  11,678
505.01.2013         
606.01.2013  23     
707.01.2013         
808.02.2013         
909.02.2013  12     
1010.02.2013         
1111.02.2013  4     
12           

verwendete Formeln
Zelle Formel Bereich
E3 =SUMMENPRODUKT((MONAT($A$1:$A$15)=MONAT(E$2&1))*($C$1:$C$15<>"")*($C$1:$C$15)) 
F3 =SUMMENPRODUKT((MONAT($A$1:$A$15)=MONAT(F$2&1))*($C$1:$C$15<>"")*($C$1:$C$15)) 
E4 =E3/SUMMENPRODUKT((MONAT($A$1:$A$15)=MONAT(E$2&1))*($C$1:$C$15<>"")) 
F4 =F3/SUMMENPRODUKT((MONAT($A$1:$A$15)=MONAT(F$2&1))*($C$1:$C$15<>"")) 

Tabellendarstellung in Foren Version 5.30


gruss hary

Anzeige
AW: wer lesen kann...
06.01.2013 15:53:24
Arno
Hallo Hary, danke für die schnelle Antwort. Leider funktioniert es bei mir nur z.T.
Ich habe Deine Tabelle und die Formeln 1:1 in ein neues Tabellenblatt übertragen, es funktioniert, also musste der Fehler bei mir liegen. Nachdem ich in Spalte C in der WENN Funktion den Sonst-Wert von "" auf 0 gesetzt habe wurde der Monatsverbrauch f. Jan korrekt angezeigt. Beim kopieren der Formelvon links (Jan) nach re (Dez) wurde die Formel ohne Fehlermeldung angenommen. Kurioserweise zeigte er bereits für den Juli den selben Wert wie für den Jan. Beim Eintragen von weiteren Testwerten, z.B. am 9.März, wurden plötzlich f. Juni und Dez Werte ausgerechnet, aber nicht f. März.
Das Problem mit dem Tagesdurchschnitt würde ich erst im nächsten Schritt lösen wollen wenn das erste klappt.
Ich hänge mal die Datei dran, hoffentlich klappt es, bin neu hier.

Die Datei https://www.herber.de/bbs/user/83269.xlsx wurde aus Datenschutzgründen gelöscht


Danke vorab.
Gruß Arno

Anzeige
AW: Nu aber
06.01.2013 17:27:27
hary
Hallo Arno
Kam erst jetzt dazu. Bei meinem Vorschlag waren noch einige Fragen offen, wie stehen die Monate drin usw.. Ich hatte halt Monat als Text genommen. Funzt bei dir natuerlich nicht.
Schau mal hier. Die gruenen Zellen sind mit neuen Formeln, dabei dein Problem auch gleich geloest wenn naechste Ablese im Maerz.
https://www.herber.de/bbs/user/83271.xlsx
gruss hary

AW: Nu aber
06.01.2013 18:37:14
Arno
Hallo Hary,
vielen Dank für Deine Mühe, und das am Wochenende!!!
Deine Lösung ist absolut perfekt, genau das, was ich gesucht habe.
Ich hoffe, bei meiner nächsten Frage werde ich wieder auf so schnelle und kompetente Hilfe
treffen.
Gruß Arno
Anzeige

347 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige