Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

prüfen, ob wert in spalte - wenn ja, wie oft

prüfen, ob wert in spalte - wenn ja, wie oft
20.08.2013 12:56:43
Vat
Hallo zusammen,
ich suche nach einer Formel mit der ich in Spalte A1:A6 prüfe, ob Werte nur einmal oder mehrfach vorkommen.
Die Eingabe (Gültigkeit ist schon begrenzt auf: A;B;C;X;Y;Z.
Nun die Krux an der Sache. A;B;C dürfen je nur einmal und müssen aber auch je einmal vorkommen. X;Y;Z können sooft sie wollen vorkommen.
Danke & Viele Grüße
Vat

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Lösung per SUMMENPRODUKT()
20.08.2013 13:02:50
NoNet
Hallo Vat,
gib in eine weitere Zelle folgende Funktion ein :
=SUMMENPRODUKT((ZÄHLENWENN($A$1:$A$6;{"A"."B"."C"})=1)*1)=3
Beispiel :
ABC
1
2
3
4
5
6

Funktionen im Tabellenblatt
Zelle Formel 
C1   =SUMMENPRODUKT((ZÄHLENWENN($A$1:$A$6;{"A"."B"."C"})=1)*1) 

Gruß, NoNet

Anzeige
AW: Lösung per SUMMENPRODUKT()
20.08.2013 13:24:16
Vat
Hallo NoNet,
die Formel funktioniert super.
Vielen Dank dafür!
Ich versuche jetzt auch noch eine bedingte Formatierung auf den Bereich zu legen, sodass sich die Zelle verfärbt, bei falscher eingabe.
mit =ZÄHLENWENN(a$1:a6;a1) >1 bekomme ich aber nur alle duplikate. Die geschweiften Klammern, aus deiner Formel, sind glaube ich nicht erlaubt.
Kannst du mich hier bitte noch einmal unterstützen?
Grüße Vat

AW: Lösung per SUMMENPRODUKT()
20.08.2013 15:13:25
Vat
Hallo nochmal,
hat noch jemand eine Idee wie ich die fehlerhaften Eintragungen direkt in der Zelle farblich hervorheben kann?
Danke
Vat

Anzeige
AW: Lösung per SUMMENPRODUKT()
21.08.2013 09:16:09
Matthias
Hallo
hat noch jemand eine Idee wie ich die fehlerhaften Eintragungen direkt in der Zelle farblich hervorheben kann?
In welcher Zelle denn ?
Bsp.
Tabelle1

 AB
1AFALSCH
2B
3X
4Y
5X
6Z

Formeln der Tabelle
ZelleFormel
B1=SUMMENPRODUKT((ZÄHLENWENN($A$1:$A$6;{"A"."B"."C"})=1)*1)=3


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Ich würde für den kompletten Bereich(A1:A6) die bedingte Formatierung setzen und prüfen ob in B1 WAHR oder FALSCH steht.
Du kannst natürlich (siehe Bsp.) auch nur A3:A6 bed.formatieren, weil in B1 FALSCH steht
und in den Zellen nicht A,B oder C steht.
Gruß Matthias

Anzeige
AW: Lösung per SUMMENPRODUKT()
21.08.2013 16:50:09
vat
Hallo Matthias,
Vielen Dank für deine Hilfe.
Zu deiner Frage. Ich möchte direkt nach Eingabe in der Zelle farblich hervorheben wenn der eingegebene Wert nicht "stimmt". Quasi soll die bedingte Formatierung ständig den Bereich (A1:A6) überwachen.
Ich vermute aber mal, dass die Formel für die bedingte Formatierung zu extrem oder nicht zulässig ist.
Ich wüsste auch gar nicht wie ich die Bedingungen ansetzen könnte.
Nach den im ersten Posting genannten Bedingungen:
Spalte A1:A6 prüfen, ob Werte nur einmal oder mehrfach vorkommen.
Die Eingabe (Gültigkeit ist schon begrenzt auf: A;B;C;X;Y;Z.
A;B;C dürfen je nur einmal und müssen aber auch je einmal vorkommen. X;Y;Z können sooft sie wollen vorkommen.

z.B.:
ABCXYZ = OK ABCXXX = OK XAYBZC =OK
AXYZXY = NOK ABXYZA = NOK ABCABC = NOK
V.G. Vat

Anzeige
machs wie vorgeschlagen, prüfe auf WAHR/FALSCH
22.08.2013 09:06:12
Matthias
Hallo
Tabelle1

 AB
1XFALSCH

Formeln der Tabelle
ZelleFormel
B1=SUMMENPRODUKT((ZÄHLENWENN($A$1:$A$6;{"A"."B"."C"})=1)*1)=3

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A11. / Formel ist =$B$1=FALSCHAbc


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Die bedingte Formatierung wendest Du an in A1:A6
Tabelle1

 AB
1XFALSCH
2A 
3B 
4B 
5Z 
6C 

Formeln der Tabelle
ZelleFormel
B1=SUMMENPRODUKT((ZÄHLENWENN($A$1:$A$6;{"A"."B"."C"})=1)*1)=3

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A11. / Formel ist =$B$1=FALSCHAbc
A21. / Formel ist =$B$1=FALSCHAbc
A31. / Formel ist =$B$1=FALSCHAbc
A41. / Formel ist =$B$1=FALSCHAbc
A51. / Formel ist =$B$1=FALSCHAbc
A61. / Formel ist =$B$1=FALSCHAbc


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Tabelle1

 AB
1AWAHR
2B 
3C 
4X 
5Y 
6Z 

Formeln der Tabelle
ZelleFormel
B1=SUMMENPRODUKT((ZÄHLENWENN($A$1:$A$6;{"A"."B"."C"})=1)*1)=3

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A11. / Formel ist =$B$1=FALSCHAbc
A21. / Formel ist =$B$1=FALSCHAbc
A31. / Formel ist =$B$1=FALSCHAbc
A41. / Formel ist =$B$1=FALSCHAbc
A51. / Formel ist =$B$1=FALSCHAbc
A61. / Formel ist =$B$1=FALSCHAbc


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Tabelle1

 AB
1AWAHR
2C 
3B 
4X 
5X 
6X 

Formeln der Tabelle
ZelleFormel
B1=SUMMENPRODUKT((ZÄHLENWENN($A$1:$A$6;{"A"."B"."C"})=1)*1)=3

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A11. / Formel ist =$B$1=FALSCHAbc
A21. / Formel ist =$B$1=FALSCHAbc
A31. / Formel ist =$B$1=FALSCHAbc
A41. / Formel ist =$B$1=FALSCHAbc
A51. / Formel ist =$B$1=FALSCHAbc
A61. / Formel ist =$B$1=FALSCHAbc


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias
Anzeige

347 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige