Microsoft Excel

Herbers Excel/VBA-Archiv

Abfrage eines best.Wertes in einer Spalte

Betrifft: Abfrage eines best.Wertes in einer Spalte von: Helmut Kirchhoff
Geschrieben am: 30.10.2012 16:11:03

Hallo Excel-Freunde,

In der anliegenden Datei gibt es in der Spalte B bestimmte Kürzel, die für einen bestimmten Dienst stehen. In der Spalte G möchte ich nun für das Kürzel B 1 den Wert 8 ausgeben. Ähnlich verhält es sich z.B bei dem Kürzel B 21. Dieser soll auch den Wert 8 ergeben. Anders verhält es sich bei dem Kürzel B2 oder B22. Dieser soll den Wert 7,5 ergeben.
Versucht habe ich es bisher mit einer normalen Wenn-Formel, auch eine wenn-oder Lösung lief nicht.

Wer kann mir weiterhelfen?
https://www.herber.de/bbs/user/82391.xlsx

Gruß Helmut

  

Betrifft: AW: Abfrage eines best.Wertes in einer Spalte von: Sheldon
Geschrieben am: 30.10.2012 16:20:40

Hallo Helmut,

so:
https://www.herber.de/bbs/user/82392.xlsx


Gruß
Sheldon


  

Betrifft: AW: Abfrage eines best.Wertes in einer Spalte von: Rudi Maintaire
Geschrieben am: 30.10.2012 16:23:36

Hallo,
=WENN(ODER(B1={"B1"."B21"});8;WENN(ODER(B1={"B2";"B22"});7,5;0))
alternativ
=((B1="B1")+(B1="B21"))*8+((B1="B2")+(B1="B22"))*7,5
=ODER(B1={"B1"."B21"})*8+ODER(B1={"B2";"B22"})*7,5

Gruß
Rudi


 

Beiträge aus den Excel-Beispielen zum Thema "Abfrage eines best.Wertes in einer Spalte"