Microsoft Excel

Herbers Excel/VBA-Archiv

Prüfen ob bestimmtes Tabellenblatt vorhanden

Betrifft: Prüfen ob bestimmtes Tabellenblatt vorhanden von: Markus
Geschrieben am: 05.11.2014 07:00:28

Folgendes Problem ...

ich möchte in einer Mappe2 auf eine Zelle aus einer Tabelle"XX" aus Mappe1 verweisen.
Die Tabelle"XX" ist aber unter Umständen nicht vorhanden.
Bei normalem Verweis erscheint dann ja immer #Bezug

um das zu vermeiden, möchte ich vorher prüfen ob es diese Tabelle"XX" gibt.
Der Name der Tabelle"XX" würde in einer Zelle z.B. A4("Ba")in der aktuellen Tabelle der Mappe2 stehen.

Aufgabe also. Prüfe (in Mappe2) ob es eine Tabelle(mit Namen der in A4 steht) in Mappe1 gibt, wenn ja gibt Wahr aus, wenn nein gibt Nein aus.

  

Betrifft: AW: Prüfen ob bestimmtes Tabellenblatt vorhanden von: Hajo_Zi
Geschrieben am: 05.11.2014 07:14:23

das geht nur über Indirekt mit Name in Zelle und dazu muss die Datei auf sein.
=WennFehler(DeineFormel;"")

GrußformelHomepage
Abspann kurz


  

Betrifft: AW: Prüfen ob bestimmtes Tabellenblatt vorhanden von: Markus
Geschrieben am: 05.11.2014 07:32:31

Ich habe das mit INDIREKT versucht und mit offener Datei, aber da kommt trotzdem nur ein #Bezug, wenn es mit INDIREKT ginge wäre ich wirklich froh, das wäre die einfachste Methode.

Vielleicht schreibe ich auch was falsch ... wie müsßte denn das ganze aussehen, wenn ich

z.B. auf Zelle BE52 in Mappe1 TabelleXX verweisen möchte und XX steht in Mappe2 TabelleYY in Zelle A4


  

Betrifft: AW: Prüfen ob bestimmtes Tabellenblatt vorhanden von: Hajo_Zi
Geschrieben am: 05.11.2014 07:33:59

dazu kann ich nichts schreiben, was wohl daran liegt, das ich Deine Formel nicht sehe.

Gruß Hajo


  

Betrifft: AW: Prüfen ob bestimmtes Tabellenblatt vorhanden von: Markus
Geschrieben am: 05.11.2014 07:54:32

ähm die Formel sollte doch mit Angabe von Mappe Tabelle und Zelle möglich sein, ohne dass meine falsche Formel bekannt sein muss ?

meine Versuche sieht so aus


=WENN(A4>0;INDIREKT([Mappe1.xlsm]A4&"!$BE$52");0)
oder einfach nur =INDIREKT([Mappe1.xlsm]A4&"!$BE$52")

das A4 bei Mappe1 steht in A4 in Mappe2

mir wäre aber auch


  

Betrifft: AW: Prüfen ob bestimmtes Tabellenblatt vorhanden von: Hajo_Zi
Geschrieben am: 05.11.2014 07:58:34


Tabelle1

 AB
4Tabelle14646

verwendete Formeln
Zelle Formel Bereich N/A
B4=WENN(A4>0;INDIREKT("[141104.xlsm]" & A4&"!$A1");0)  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.20 einschl. 64 Bit



Gruß Hajo


  

Betrifft: AW: Prüfen ob bestimmtes Tabellenblatt vorhanden von: Markus
Geschrieben am: 05.11.2014 08:16:39

irgendwo habe ich anscheinend einen Denkfehler .... das mit dem Wenn ist glaub ich falsch durchdacht

die Formel funktioniert, wenn es die Tabelle mit dem Namen A4 gibt in Mappe1 gibt
Wenn es aber die Tabelle nicht gibt kommt weiterhin ein ungültiger Bezug

auch diese Formel bringt nur einen ungültigen Bezug
INDIREKT("[141104.xlsm]" & A4&"!$A1")


  

Betrifft: AW: Prüfen ob bestimmtes Tabellenblatt vorhanden von: Hajo_Zi
Geschrieben am: 05.11.2014 08:19:13

ja meine Lösung aus dem ersten Beitrag gefiel Dir ja nicht, weiteren Vorschlag habe ich nicht.

Gruß Hajo


  

Betrifft: AW: Prüfen ob bestimmtes Tabellenblatt vorhanden von: Markus
Geschrieben am: 05.11.2014 08:24:53

sorry das habe ich ganz verpasst ? das mit WennFehler ... scheint zu funktionieren

SORRY SORRY !!!!
man sollte immer alles lesen und versuchen es gleich zu verstehen :-)


  

Betrifft: AW: Prüfen ob bestimmtes Tabellenblatt vorhanden von: Hajo_Zi
Geschrieben am: 05.11.2014 08:27:04

warum offen?

GrußformelHomepage


 

Beiträge aus den Excel-Beispielen zum Thema "Prüfen ob bestimmtes Tabellenblatt vorhanden"