Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Unterschiedl. Werte in Spalte bestimmen + Ausgabe

Unterschiedl. Werte in Spalte bestimmen + Ausgabe
01.03.2015 15:07:44
Joerschi
Hallo liebes Forum,
Folgendes Problem bzw. Ausgangslage:
Spalte A1:A40 enthält Basiswerte.
Spalte B1:B40 enthält absteigend Zahlen-Prozentwerte.
In Spalte B soll von oben nach unten für jeden "neuen/unterschiedlichen" Wert gesucht werden.
In Spalte D untereinander ausgegeben werden soll jedoch stets der "zugehörige" Wert aus Spalte A (ohne Leerzellen dazwischen, also hintereinander weg).
Achtung: Wenn in Spalte B mehrere gleiche Werte direkt untereinander stehen, ist nur der unterste davon relevant und zu beachten.
Gesucht wird demnach eine Formelansatz in Spalte D :-)
Im Beispiel ist mit einem "x" markiert, welche Zeile (bzw. A-Spaltenwerte in der Ausgabe) das hier betreffen würde:
Userbild
Musterdatei: https://www.herber.de/bbs/user/96089.xlsx
Hat jemand einen Rat, wo man ansetzen könnte?
Danke vora

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Unterschiedl. Werte in Spalte bestimmen + Ausgabe
01.03.2015 15:38:08
{Boris}
Hi,
C1:
=WENN(B2<B1;"x";"")
und runterkopieren.
VG, Boris

AW: Unterschiedl. Werte in Spalte bestimmen + Ausgabe
01.03.2015 19:53:29
Josef
Hallo
Wenn die null Prozent in Zelle B40 auf 0.001% erhöhen kannst wird das noch relativ einfach.
Bei einer Null in B40 versagt ja auch die Formel von Boris für die Spalte C
Gruss Sepp
Tabelle1

 ABCD
10,00%100,00%x0,00%
20,50%88,61%x0,50%
31,00%84,81%x1,00%
41,50%73,42%x1,50%
52,00%70,89%x2,00%
62,50%67,09%x2,50%
73,00%64,56%x3,00%
83,50%56,96%x3,50%
94,00%54,43%x4,00%
104,50%51,90%x4,50%
115,00%50,63%x5,00%
125,50%45,57%x5,50%
136,00%41,77%x6,00%
146,50%39,24%x6,50%
157,00%37,97%x7,00%
167,50%32,91% 8,00%
178,00%32,91%x8,50%
188,50%29,11%x9,00%
199,00%27,85%x9,50%
209,50%24,05%x10,00%
2110,00%17,72%x10,50%
2210,50%13,92%x11,00%
2311,00%12,66%x12,00%
2411,50%11,39% 12,50%
2512,00%11,39%x13,00%
2612,50%10,13%x13,50%
2713,00%8,86%x17,00%
2813,50%6,33%x17,50%
2914,00%3,80% 19,00%
3014,50%3,80% 19,50%
3115,00%3,80%  
3215,50%3,80%  
3316,00%3,80%  
3416,50%3,80%  
3517,00%3,80%x 
3617,50%2,53%x 
3718,00%1,27%  
3818,50%1,27%  
3919,00%1,27%x 
4019,50%0,00%x 

Formeln der Tabelle
ZelleFormel
D1{=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(B$2:B$51<B$1:B$50;ZEILE($1:$50)); ZEILE(A1))); "")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4,8

Anzeige
AW: Unterschiedl. Werte in Spalte bestimmen + Ausgabe
01.03.2015 20:04:44
Joerschi
Hallo Sepp,
besten Dank für die Antwort (auch @Boris).
Komplexer als ich gehofft hatte (wenn ohne Leerzellen).
Die Änderung auf 0,001%kann ich manuell reinpacken - dies ist eine gute Stütze. Gute Idee!
Liebe Grüße
Joerschi

317 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige