VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Tabelle nach mehreren Kriterien summieren

Gruppe

Matrix

Bereich

Matrixfunktion

Thema

Tabelle nach mehreren Kriterien summieren

Problem

Wie kann ich einen Tabellenbereich nach mehreren Kriterien summieren. Die Excel-Funktion SUMMEWENN akzeptiert nur ein Kriterium.

Lösung

Folgende Matrixformel: {=SUMME((A1:A100="K-FF 1655")*(B1:B100="Hespe")*C1:C100)}




StandardModule: basMain

Sub Filtern()
   Range("A1").Select
   Selection.AutoFilter Field:=8, Criteria1:=">" & _
      CDbl(DateValue(Range("Datum1").Text)), Operator:=xlAnd, _
      Criteria2:="<" & CDbl(DateValue(Range("Datum2").Text))
 End Sub

    


Beiträge aus dem Excel-Forum zu den Themen Matrix und Matrixfunktion