Microsoft Excel

Herbers Excel/VBA-Archiv

SVerweis mit Tabellename (matrix) als Variable

Betrifft: SVerweis mit Tabellename (matrix) als Variable von: erkoo
Geschrieben am: 05.06.2008 13:42:26

Hallo zusammen,

ich möchte gerne, das mein sverweis Funktion den Tabellennamen für die Matirx von einer Zelle bekommt.
Also so was steht in Tabelle4:
Zelle A1: Tabelle1
Zelle A2: Tabelle2
Zelle A3: Tabelle3

Zelle B1: A
Zelle B2: B
Zelle B3: C

Zelle C1: =SVERWEIS(B1;A1&"!$A:$C";2;FALSCH)
Zelle C2: =SVERWEIS(B2;A2&"!$A:$C";2;FALSCH)
Zelle C3: =SVERWEIS(B3;A3&"!$A:$C";2;FALSCH)

Ich bekomme immer einen #WERT fehler.

Hat jemand eine Idee, wie ich das Lösen kann?

Danke im Voraus!
erko

  

Betrifft: AW: SVerweis mit Tabellename (matrix) als Variable von: David
Geschrieben am: 05.06.2008 13:44:09

Versuchs mal so:

Zelle C1: =SVERWEIS(B1;Indirekt(A1&"!$A:$C");2;FALSCH)

Gruß

David


  

Betrifft: AW: SVerweis mit Tabellename (matrix) als Variable von: erkoo
Geschrieben am: 05.06.2008 14:12:12

Hallo David,
super vielen Dank!
Jetzt weis ich auch wo der Fehler lag.
Ich habe als Tabellenname "I-ABC" gehabt und er hat mit dem Minus ein Problem.
Gruß
erko


 

Beiträge aus den Excel-Beispielen zum Thema "SVerweis mit Tabellename (matrix) als Variable"