Microsoft Excel

Herbers Excel/VBA-Archiv

Sverweis mit 2 Werten

Betrifft: Sverweis mit 2 Werten von: Werner
Geschrieben am: 14.09.2004 12:36:10

Hallo Leute,


Ich habe ein Problem mit Sverweis.
Meine Formel lautet:

=WENN(H2=0;0;SVERWEIS(H2;Einzelteile!$A$2:$D$2500;3;FALSCH))
Das Suchkriterium soll H2 und A1 sein und nur wenn beide übereinstimmen soll die Spalte 3 ausgegeben werden.
Der Wahrheitswert "FALSCH" gibt #NV aus. Kann man das so ändern, das z.b. keine BDT ausgegeben wird?

  


Betrifft: AW: Sverweis mit 2 Werten von: Reinhard
Geschrieben am: 14.09.2004 12:41:02

Hi Werner,
probier mal:
=WENN(H2=0;0;WENN(ISTNV(SVERWEIS(H2;Tabelle2!$A$2:$D$2500;3;FALSCH));"keine BDN";SVERWEIS(H2;Tabelle2!$A$2:$D$2500;3;FALSCH)))
Gruß
Reinhard


  


Betrifft: AW: Sverweis mit 2 Werten von: werner
Geschrieben am: 14.09.2004 12:45:18

Hallo Reinhardt

da wird in allen Zellen keine BDT eingetragen.

Werner


  


Betrifft: AW: Sverweis mit 2 Werten von: Reinhard
Geschrieben am: 14.09.2004 12:52:17

Hi Werner,
nein, meine Formel ist korrekt:
https://www.herber.de/bbs/user/10868.xls
Gruß
Reinhard


  


Betrifft: AW: Sverweis mit 2 Werten von: Werner
Geschrieben am: 14.09.2004 13:54:04

Hi Reinhadt,

ich habe einen Fehler gemacht beim einfügen.
Die Formel lautet jetzt:

=WENN(H2=0;0;WENN(ISTNV(SVERWEIS(H2;Einzelteile!$A$2:$D$2500;3;FALSCH));"keine BDN";SVERWEIS(H2;Einzelteile!$A$2:$D$2500;3;FALSCH)))

wird da wirklich nach den inhalten der beiden Zellen H2 und A2 verglichen? Ich sehe nur H2.

Eines habe ich aber vergessen zu beschreiben.
Auf dem Blatt Einzelteile sind die Daten, die verglichen werden sollen in den Spalten A und B
Werner


  


Betrifft: AW: Sverweis mit 2 Werten von: Reinhard
Geschrieben am: 14.09.2004 22:15:48

Hi Werner,
lade mal ne kleine Beispieldatei hoch, mit gleichem Strukturaufbau und gleichem Fehler. biegen wir schon hin dass es läuft.
Gruß
Reinhard


  


Betrifft: AW: Sverweis mit 2 Werten von: Werner
Geschrieben am: 15.09.2004 08:11:16

Hi Reinhardt,

die Datei habe ich mal hochgeladen, schau sie dir mal an.

https://www.herber.de/bbs/user/10893.xls


Werner


  


Betrifft: AW: Sverweis mit 2 Werten von: Reinhard
Geschrieben am: 15.09.2004 14:28:10

Hi Werner,
so klappts nach meinem Verständnis:
https://www.herber.de/bbs/user/10905.xls
Gruß
Reinhard


  


Betrifft: AW: Sverweis mit 2 Werten von: Reinhard
Geschrieben am: 15.09.2004 14:29:08

Hi Werner,
so klappts nach meinem Verständnis:
https://www.herber.de/bbs/user/10905.xls
Gruß
Reinhard


 

Beiträge aus den Excel-Beispielen zum Thema "Sverweis mit 2 Werten"