Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Mittelwert an 2 Bedingungen geknüpft

Mittelwert an 2 Bedingungen geknüpft
10.12.2012 09:31:02
Julia

Hallo,
ich habe folgendes Problem: Beispiel Testdatei: https://www.herber.de/bbs/user/82955.xlsx
Ich will den Mittelwert aus Spalte C,aber nur wenn in Spalte B ein x vorkommt und in Spalte C der Wert größer 0 ist. Jetzt habe ich schon einiges ausprobiert, bekomme aber nie das gewünschte Ergebnis. Das Problem liegt denke ich in der Zählenwenn-Funktion die an die beiden Bedingungen geknüpft ist. Irgendwas mach ich da falsch.
Danke für die Hilfe.
LG Julia

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Mittelwert an 2 Bedingungen geknüpft
10.12.2012 09:57:05
hary
Hallo
Eine Moeglichkeit.
Tabelle1
 FG
2Mittelwert7,6538
3korekkter Mittelwert wäre7,6538

verwendete Formeln
Zelle Formel Bereich
G2 =SUMMENPRODUKT((B2:B10000="x")*(C2:C10000>0)*(C2:C10000))/SUMMENPRODUKT((B2:B10000="x")*(C2:C10000>0)) 

Tabellendarstellung in Foren Version 5.30


gruss hary

Anzeige
AW: Mittelwert an 2 Bedingungen geknüpft
10.12.2012 10:08:27
silex1
Hallo,
geht auch per Matrixformel:
{=MITTELWERT(WENN((B2:B10000="x")*(C2:C10000>0)*(C2:C10000);C2:C10000))}
vg René

AW: Mittelwert an 2 Bedingungen geknüpft
10.12.2012 11:05:52
Julia
Super danke.

333 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige