Live-Forum - Die aktuellen Beiträge
Anzeige
Archiv - Navigation
1568to1572
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Verweis mit mehreren Suchkriterien

Verweis mit mehreren Suchkriterien
21.07.2017 15:49:20
Kate187
Ich benötige Hilfe beim Aufbau eines Sverweises mit vier Suchkriterien.
Drei von vier Suchkriterien sind Werte die mit zwei Spalten abgeglichen werden müssen. D.h. wenn das Suchkriterien zwischen zwei Werten liegt, soll nach dem nächsten Suchkriterium gesucht werden.
Die Datei findet Ihr im Anhang.
Ich habe es mit Sverweis verschatelt mit Wenn-Funktionen versucht und mit Index/Vergleich.. leider habe ich keine vernünftige Lösung für mein Problem gefunden...
Ich hoffe hier einige Tipps zu finden...
https://www.herber.de/bbs/user/114996.xlsx

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: mit VERWEIS() ...
21.07.2017 17:06:19
...
Hallo Kate,
... in E4:
=WENNFEHLER(VERWEIS(9;1/(A$20:A$29=A4)/(B$20:B$29=B4)/(D$20:D$29=C4)/(F$20:F$29=D4);H$20:H$29);"?")
und Formel nach unten kopieren.
Gruß Werner
.. , - ...
mit SUMMENPRODUKT()
21.07.2017 17:58:13
Frank
oder ...
=SUMMENPRODUKT(((A$20:A$27=A4)*(B4>=B$20:B$27)*(B4=D$20:D$27)*(C4=F$20:F$27)*(D4

AW: funktioniert im Beispiel, aber nicht immer ...
21.07.2017 19:31:07
...
Hallo Frank,
... ich rate deshalb vom Einsatz von SUMMENPRODUKT() zur Ermittlung eines Ergebniswertes in Abhängigkeit eines Suchwertes (egal ob ohne oder mit zusätzlichen Bedingung(en) wie hier im thread) prinzipiell ab.
Es sei denn, man ist sich ganz 100% sicher, dass stets eindeutig nur ein Ergebnis gefunden werden wird. Bei den vorgegebenen Beispieldaten ist das der Fall, aber wer überschaut das bei mehr Datensätzen schon wirklich immer, mal ganz davon abgesehen, was später evtl. noch an den Daten geändert/ergänzt werden könnte.
Wenn die Standardfunktion(en) SVERWEIS() oder VERWEIS() oder INDEX() und VERGLEICH() nicht einfach zum Ziel führen (wie hier im thread), dann z.B. eine derartige Formel wie von mir aufgezeigt oder eine Formel mit oder INDEX() und AGGREGAT() oder eine Matrixformel mit INDEX() und MIN() oder ... aber keine SUMMENPRODUKT()-Formel.
Eine VERWEIS()-Formel listet zwar bei mehreren Treffern immer den letzten Treffer, eine INDEX()-AGGREGAT()-Formelkonstruktion zunächst immer nur den ersten Treffer, aber beide Ergebnisse sind wenigstens korrekt, wenn auch nicht inhaltlich vollständig. Dagegen liefert in so einem Fall eine SUMMENPRODUKT()-Formel immer etwas völlig falsches.
Mit erweiterten (willkürlich ergänzten Datensätze Zeile 28:29) Beispieldaten beweise ich nachfolgend vorgenanntes.
Bei evtl. Hinweisen und Rückfragen zu meinen Aussagen kann ich allerdings hier im thread nicht mehr reagieren, weil ich gleich für mehrere Tage offline gehen werde. Anfang August ist dieser thread dann aber bereits deaktiviert.
 ABCDEFGH
3EinsatzmaterialBreiteDickeEnddickeAnzahl MinAnzahl Min  
4AA6001,20,41111  
5AA640312222  
6AA700314444  
7BB1600235555  
8BB164034,56666  
9BB170033111210  
10        
17        
18Suchmatrix       
19EinsatzmaterialBreite minBreite maxDicke minDicke maxEnddicke minEnddicke maxAnzahl Min
20AA500660120,40,811
21AA500660240,81,222
22AA670800120,40,833
23AA670800240,81,244
24BB15001660122455
25BB15001660244666
26BB16701800122477
27BB16701800244688
28BB17002000242499
29BB170020003635111

Formeln der Tabelle
ZelleFormel
E4=WENNFEHLER(VERWEIS(9;1/(A$20:A$31=A4)/(B$20:B$31<=B4)/(C$20:C$31>=B4)/(D$20:D$31<=C4)/(E$20:E$31>=C4)/(F$20:F$31<=D4)/(G$20:G$31>=D4); H$20:H$31); "?")
F4=SUMMENPRODUKT(((A$20:A$29=A4)*(B4>=B$20:B$29)*(B4<=C$20:C$29)*(C4>=D$20:D$29)*(C4<=E$20:E$29) *(D4>=F$20:F$29)*(D4<=G$20:G$29)); H$20:H$29)

Gruß Werner
.. , - ...
Anzeige
Recht du hast... ... ich weiß
21.07.2017 20:04:00
Frank
... hallo Werner. Aber ich halte meist an die jeweilige Anfrage.
AW: funktioniert im Beispiel, aber nicht immer ...
21.07.2017 20:28:23
Kate187
Vielen Dank für die schnellen Lösungsvorschläge!!!
Am Montag werde ich es noch mit weiteren Daten testen.
Gibt es irgendwo eine einfache Erläuterung zu der Anwendung der o.g. Formeln?
Ich habe bisher die Formeln in der Praxis nicht so oft angewendet und ich finde es extrem schwierig die von allein so aufzubauen...

322 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige