Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Summeprodukt mit mehrere Kriterien in einer Zelle

Summeprodukt mit mehrere Kriterien in einer Zelle
25.07.2019 11:35:25
Robert
Hallo zusammen,
ich habe folgendes Problem:
in einem Blatt befinden sich 2 Tabelle:
Tabelle 1 sollte die Summe nach ausgewählten Kriterien bilden und Tabelle 2 hat die Daten, die summiert werden sollen.
In Tabelle 1 (Spalte B) werden die Namen (mehr als 1) der Mitarbeiter ausgewählt, die in Tabelle 2 Spalte K befinden!
In Tabelle 1 Spalte C bzw. D sollte sich die Summe zb von Arbeitstage bzw. Umsatz für die ausgewählte Mitarbeiter in Spalte B ergeben. Hab diese Formel genutzt, aber leider kommt es #NV oder #Wert
=WENN([@Mitarbeiter]="";"";SUMMENPRODUKT(L2:L38*ISTZAHL(FINDEN(K2:K40;[@Mitarbeiter]))))
Datei ist hier:
https://www.herber.de/bbs/user/131066.xlsx
Kann jemand mich bitte den Fehler finden und es korrigieren=
Wäre echt ne große Hilfe!
Danke im Voraus,
Ro

11
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Summeprodukt mit mehrere Kriterien in einer Zelle
25.07.2019 11:40:37
Daniel
Hi
in solchen Matrixformeln müssen die Zellbereiche, die in der Matrix verwendet werden, immer genau gleich groß sein, bei dir sind sie das nicht (2:38 und 2:40)
Gruß Daniel
AW: Summeprodukt mit mehrere Kriterien in einer Zelle
25.07.2019 11:44:55
Daniel
Hi
in solchen Matrixformeln müssen die Zellbereiche, die in der Matrix verwendet werden, immer genau gleich groß sein, bei dir sind sie das nicht (2:38 und 2:40)
Gruß Daniel
AW: Summeprodukt mit mehrere Kriterien in einer Zelle
25.07.2019 11:54:24
Robert
Habe leider nicht verstanden, was genau du damit meinst...
AW: Summeprodukt mit mehrere Kriterien in einer Zelle
25.07.2019 12:00:07
Daniel
=WENN([@Mitarbeiter]="";"";SUMMENPRODUKT(L2:L38*ISTZAHL(FINDEN(K2:K40;[@Mitarbeiter]))) )
die fett markierten Zellbereiche müssen gleich groß sein.
dh wenn beide Zellbereiche in der gleichen Zeile anfangen, müssen sie auch in der gleichen Zeile aufhören.
Gruß Daniel
Anzeige
AW: Summeprodukt mit mehrere Kriterien in einer Zelle
25.07.2019 12:05:12
Robert
Hab es gemacht, wieder Fehler...
AW: Summeprodukt mit mehrere Kriterien in einer Zelle
25.07.2019 12:26:42
SF
Hola,
und wie sieht deine Formel jetzt aus?
Ist das beabsichtigt dass du die Bereiche in der Formel nicht fixiert hast und die sich somit beim Ziehen der Formel verändern?
Gruß,
steve1da
AW: Summeprodukt mit mehrere Kriterien in einer Zelle
25.07.2019 12:48:04
Robert
https://www.herber.de/bbs/user/131073.xlsm
hier kannst es bitte nochmal schauen? Wenn ich den Blatt in in neue Datei alleine einfüge, funktioniert super..in dieser Datei funktioniert es leider nicht...verstehe nicht warum...
AW: Summeprodukt mit mehrere Kriterien in einer Zelle
25.07.2019 12:58:33
SF
Hola,
durch die "" in deiner Formel in Spalte L erzeugst du TEXT. Ändere das in eine 0 und lass die Nullwerte hier ausblenden über das Zellformat:
0;-0;;@
Gruß,
steve1da
Anzeige
AW: Summeprodukt mit mehrere Kriterien in einer Zelle
25.07.2019 13:10:43
Robert
Vieeeelen Dank...Es hat super geklappt!!!! Schönen Tag :)
AW: Summeprodukt mit mehrere Kriterien in einer Zelle
25.07.2019 13:03:41
Daniel
Hi
schau dir mal die Formeln in der Spalte L an.
die leeren Zellen sind nicht wirklich leer, sondern enthalten den Text "" (Leerstring).
das sieht zwar leer aus, ist technisch aber Text.
um die Multiplikation durchführen zu können, muss Excel diesen Text in eine Zahl umwandeln, dazu muss der Text aber wie eine Zahl aussehen und der Leerstring tut das nicht. Daher dann der Fehler.
schreibe die Formel mal so, dann geht's (der relvante Teil ist fett markiert):
=WENN([@Mitarbeiter]="";"";SUMMENPRODUKT(L2:L40;1*ISTZAHL(FINDEN(K2:K40;[@Mitarbeiter]))))
Gruß Daniel
Anzeige
AW: Summeprodukt mit mehrere Kriterien in einer Zelle
25.07.2019 13:11:23
Robert
Das hat auch super funktioniert...ganz ganz lieben dank!! :))))

380 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige