2 Ergebnisse in einem Feld darstellen



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: 2 Ergebnisse in einem Feld darstellen
von: Mindjogger
Geschrieben am: 01.07.2002 - 16:16:11


Hallo,

ich möchte in einem Excelfeld 2 Ergebnisse darstellen.

Es geht wieder einmal um die Arbeitszeit. Folgende Struktur als Beispiel

A1 Wochentag
B1 Anfangszeit
C1 Endzeit
D1 Stunden in folgender Notation:
(ges. AZ / Tag) Ü-Std.

Beispiel:
A1 5.6.02
B1 07:00
C1 19:00
D1 (12,0) 4,0

Die Berechnung habe ich soweit gelöst, aber wie belomme ich beides in einem Feld dargestellt ? Ich weiß das es irgendwie geht, nur nicht wie.


Danke für jeden Ansatz.


Bernhard Stillger, Frankfurt

nach oben   nach unten

Re: 2 Ergebnisse in einem Feld darstellen
von: Joachim L.
Geschrieben am: 01.07.2002 - 16:31:38

Hallo Bernhard,
da ich nicht weiß, wie Du die Ergebnisse bekommst, hier 2 Beispiele:
Ergebnisse in Zellen (z.B. A12 und B12) dann in D1:
= A12 & B12 Verkettung ohne Leerzeichen.
= A12 & " " & B12 Verkettung mit Leerzeichen.

Ergebnisse in Variablen (ARBEITZ und UEBERST) dann in D1:
= ARBEITZ & "/" & UEBERST Verkettung durch einen SChrägstrich getrennt.

Wichtig: Die Verkettung erfolgt über das kaufmännische Und (&)
Gruß Joachim

nach oben   nach unten

Re: 2 Ergebnisse in einem Feld darstellen
von: Russi
Geschrieben am: 01.07.2002 - 16:38:31

Du kannst alle Felder in "Text" umformatieren und dann mit dem
Befehl '=verketten(A1;" ";B1;" ";C1;" ";D1)' arbeiten.

Aus mit als Text formatierten Zellen kannst Du Berechnungen anstellen.

Ist Dir damit geholfen?


nach oben   nach unten

Re: 2 Ergebnisse in einem Feld darstellen
von: Mindjogger
Geschrieben am: 01.07.2002 - 16:40:02

Hallo und Danke es Funktioniert.

Nur leider veliert er bei Zahle jedwege Formatierung.

Derzeitiges Ergebnis : (13) 5
oder
Derzeitiges Ergebnis : (13,5) 5,5

Und das sieht in der Liste blöd aus :-(

Gewünscht ist: (13,0) 5,0
Also immer mit 1 nachkommastelle.

Derzeit benutze ich :

=WENN(C6="";" ";"("&((D6-C6)*24)&") "& ((D6-C6)*24)-8)

Aber da fehlt noch ein Formatbefehl für die Einzelnen Ergebnisse.
Und außerdem arbeiten wir am Freitag "nur" 7,5 Stunden. Aber das kriege ich schon (hoffentlich)

Gruß


Bernhard Stillger, Frankfurt

nach oben   nach unten

Re: 2 Ergebnisse in einem Feld darstellen
von: Mindjogger
Geschrieben am: 01.07.2002 - 16:40:30

Hallo und Danke es funktioniert.

Nur leider veliert er bei Zahle jedwege Formatierung.

Derzeitiges Ergebnis : (13) 5
oder
Derzeitiges Ergebnis : (13,5) 5,5

Und das sieht in der Liste blöd aus :-(

Gewünscht ist: (13,0) 5,0
Also immer mit 1 nachkommastelle.

Derzeit benutze ich :

=WENN(C6="";" ";"("&((D6-C6)*24)&") "& ((D6-C6)*24)-8)

Aber da fehlt noch ein Formatbefehl für die Einzelnen Ergebnisse.
Und außerdem arbeiten wir am Freitag "nur" 7,5 Stunden. Aber das kriege ich schon (hoffentlich)

Gruß


Bernhard Stillger, Frankfurt

nach oben   nach unten

Re: 2 Ergebnisse in einem Feld darstellen
von: Mindjogger
Geschrieben am: 01.07.2002 - 16:47:57

Habe die Lösung,

oder besser den ersten Ansatz:

=WENN(C6="";" ";"("&TEXT(((D6-C6)*24);("0,0")&") "& TEXT(((D6-C6)*24)-8;"0,0")))

Gruss


bernhard Stillger, Frankfurt

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "2 Ergebnisse in einem Feld darstellen"