Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema Image
BildScreenshot zu Image Image-Seite mit Beispielarbeitsmappe aufrufen

2 Bedingungen - ZÄHLENWENN

Betrifft: 2 Bedingungen - ZÄHLENWENN von: Toby
Geschrieben am: 10.08.2008 18:26:24

Hi!

Unten meine aktuelle Formel. Nun möchte ich aber, daß Excel zählen soll, wenn es ungleich X und ungleich Leerfeld ist.
Oder er soll nur dann zählen, wenn eine Zahl drin steht.

=ZÄHLENWENN(C3:AJ3;"<>X")

Bestimmt leicht für euch ...

Danke, Toby ...

  

Betrifft: AW: 2 Bedingungen - ZÄHLENWENN von: Klaus-Dieter
Geschrieben am: 10.08.2008 18:40:43

Hallo Toby,

bei mehr als einer Bedingung musst du mit Summenprodukt arbeiten.



Viele Grüße Klaus-Dieter

Klaus-Dieter's Excel und VBA Seite
Online-Excel






  

Betrifft: AW: 2 Bedingungen - ZÄHLENWENN von: Micki K.
Geschrieben am: 10.08.2008 18:42:49

hi

=ZÄHLENWENN(B1:B9;"<>x")-ANZAHLLEEREZELLEN(B1:B9)
oder
=SUMMENPRODUKT(ISTZAHL(B1:B9)*1)

schöne Woche, Michael
(Zellbezug müsste noch angepasst werden)


  

Betrifft: AW: 2 Bedingungen - ZÄHLENWENN von: Toby
Geschrieben am: 10.08.2008 18:46:46

DANKE


 

Beiträge aus den Excel-Beispielen zum Thema "2 Bedingungen - ZÄHLENWENN"