Microsoft Excel

Herbers Excel/VBA-Archiv

Formel verändern

Betrifft: Formel verändern von: Josef
Geschrieben am: 12.08.2008 14:51:27

Guten Tag zusammen,

möchte unten stehende Formel so ändern, das der komplette Bereich (M3:M400) zwar berücksichtigt wird,
die Summierung aber nur bist HEUTE() geht.
Wenn dies überhaupt machbar ist, kann mir denn bitte jemand behilflich sein, die Formel abzuändern?

SUMMEWENN(INDIREKT(D2&"!M3:M400");"größer 0";INDIREKT(D2&"!M3:M400"))

Danke schon mal

Grüsse
Josef

  

Betrifft: AW: Formel verändern von: David
Geschrieben am: 12.08.2008 14:56:10

=SUMMENPRODUKT((INDIREKT(D2&"!M3:M400")>0)*(INDIREKT(D2&"!M3:M400")<=heute())*(INDIREKT(D2&"!M3:M400) ))

(ungetestet)

Gruß

David


  

Betrifft: AW: Formel verändern jetzt mit Datum von: Josef
Geschrieben am: 12.08.2008 15:01:36

Hallo zusammen

Sorry, dass Datum steht in A3:A368.

Grüsse

Josef


  

Betrifft: AW: Formel verändern jetzt mit Datum von: David
Geschrieben am: 12.08.2008 15:03:26

Dann schau dir meine Formel an und ändere den Bereich entsprechend, dabei darauf achten, dass alle definierten Bereich die gleiche Länge haben.

Gruß

David


  

Betrifft: AW: Formel verändern jetzt mit Datum von: Josef
Geschrieben am: 12.08.2008 16:50:52

Hallo David,

erstmal Danke für Deine Hilfe. Wahrscheinlich habe ich mein Prob nicht richtig beschrieben. Das Datum und
die zu summierenden Werte, stehen immer in der gleichen Zeile.

Die Formel sollte folgendes berechnen:

Summiere mir alle Stunden in Spalte M3:M368, bis zum heutigen Datum (A3:A368).

David, ich weiß nicht wie ich Deine Formel abändern soll um ein richtiges Resultat zu bekommen.

Würdest Du mir bitte noch einen Tipp geben, was ich umschreiben bzw. in Deiner Formel ändern soll?

Danke

Gruß
Josef


  

Betrifft: AW: Formel verändern jetzt mit Datum von: David
Geschrieben am: 13.08.2008 08:08:14

=SUMMENPRODUKT((A3:A368<=HEUTE())*M3:M368) wäre prinzipiell für deine letzte Frage die Lösung. Wobei man theoretisch auch auf SUMMEWENN zurückgreifen könnte, aber in deinem ersten Posting hattest du noch das Kriterium ">0" mit drin, das ist jetzt nicht eindeutig, ob das weiterhin gilt. Auch den INDIREKT-Teil musst du dann noch selbst einbauen, aber das sollte machbar sein.

Es wäre prinzipiell schön, wenn du potentiellen Helfern ALLE notwendigen Informationen zur Verfügung stellst und nicht nach und nach ein paar Brocken hinwirfst.

Gruß

David


  

Betrifft: Formel ändern von: Josef
Geschrieben am: 13.08.2008 09:17:52

Guten Morgen David,

Vielen Dank erstmal, dass Du mir nochmal weitergeholfen hast. Diese "grösser 0" brauche ich eigentlich nicht, ist mir aber jetzt erst aufgefallen.

Normalerweise baue ich immer ein Muster zu meiner Bitte um Hilfe, das hatte ich diesesmal versäumt, Sorry.

David, werde gleich mal versuchen den INDIREKT-Teil in die obige Formel einzuarbeiten.

Nochmals Vielen Dank für Deine Hilfe

Gruß
Josef


 

Beiträge aus den Excel-Beispielen zum Thema "Formel verändern "