Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema MsgBox
BildScreenshot zu MsgBox MsgBox-Seite mit Beispielarbeitsmappe aufrufen

Nur Felder zählen die farblich markiert sind?

Betrifft: Nur Felder zählen die farblich markiert sind? von: Frank
Geschrieben am: 11.08.2008 07:36:44

Hallo zusammen,

besteht die Möglichkeit das Excel nur Felder aus einer Spalte zählt, die mit dem Farbtopf z.B. gelb markiert sind?

Wäre für Hilfestellung dankbar!

Viele Grüße und eine angenehme Woche

Frank

  

Betrifft: AW: Nur Felder zählen die farblich markiert sind? von: serge
Geschrieben am: 11.08.2008 07:51:05

Hallo Frank
siehe mal hier nach, unter Farbsumme:

http://hajo-excel.de/vba_fuellfarbe.htm

Gruss Serge


  

Betrifft: AW: Nur Felder zählen die farblich markiert sind? von: Beverly
Geschrieben am: 11.08.2008 08:12:00

Hi Frank,

definiere über Einfügen -> Namen einen Namen, z.B. "Füllfarbe" und gib unter Bezieht sich auf diese Formel an =ZELLE.ZUORDNEN(63;INDIREKT("ZS(-1)";)). In die Spalte rechts neben deine Zählspalte schreibst du =Füllfarbe und kopierst sie runter. Dadurch wird der Farbindex der Füllfarbe jeder Zelle links davon ausgegeben. Anschließend kannst du mittels ZÄHLENWENN() die Anzahl ermitteln.


GrußformelBeverly's Excel - Inn


  

Betrifft: AW: Nur Felder zählen die farblich markiert sind? von: Frank
Geschrieben am: 11.08.2008 08:23:49

Vielen Dank euch beiden.
Die Formel von Karin kommt mir mehr entgegen. Allerdings habe ich noch etwas vergessen zu erwähnen: Die Felder die farblich markiert sind enthalten Ziffern, diese farblich markierten Ziffern sollen summiert werden; geht das auch?


  

Betrifft: AW: Nur Felder zählen die farblich markiert sind? von: Beverly
Geschrieben am: 11.08.2008 09:05:43

Hi Frank,

für die Summe kannst du SUMMEWENN() verwenden (die Zellen A27, A29, A32, A33 und A36 haben Füllfarbe Gelb)



Tabellenblattname: Tabelle1

 

A

B

C

D

25

Daten

Index Füllfarbe

 

Summe aus gelben Zellen

26

3

0

 

21

27

5

6

 

 

28

6

0

 

 

29

5

6

 

 

30

4

0

 

 

31

3

0

 

 

32

2

6

 

 

33

3

6

 

 

34

4

0

 

 

35

5

0

 

 

36

6

6

 

 

37

7

0

 

 


Benutzte Formeln:
B26: =Füllfarbe
D26: =SUMMEWENN(B26:B37;6;A26:A37)
B27: =Füllfarbe
B28: =Füllfarbe
B29: =Füllfarbe
B30: =Füllfarbe
B31: =Füllfarbe
B32: =Füllfarbe
B33: =Füllfarbe
B34: =Füllfarbe
B35: =Füllfarbe
B36: =Füllfarbe
B37: =Füllfarbe


GrußformelBeverly's Excel - Inn


  

Betrifft: AW: Nur Felder zählen die farblich markiert sind? von: Matthias L
Geschrieben am: 11.08.2008 09:08:30

Hallo Frank
so hab ich es verstanden

Ersetze die 63 durch 24
Damit erhälst Du den Farbindex der Schrift.









hier der Code zum Kopieren:

Option Explicit

Sub Font_Color()
Dim x As Long, j As Long
For x = 1 To Len(ActiveCell.Value)
 With ActiveCell.Characters(Start:=x, Length:=1).Font
     If .ColorIndex = 5 Then j = j + 1
 End With
Next
MsgBox j & " Zeichen haben colorindex 5"
End Sub



Gruß Matthias


 

Beiträge aus den Excel-Beispielen zum Thema "Nur Felder zählen die farblich markiert sind?"