Microsoft Excel

Herbers Excel/VBA-Archiv

Fehlermeldung #BEZUG evtl. umgehen?

Betrifft: Fehlermeldung #BEZUG evtl. umgehen? von: Josef_T
Geschrieben am: 18.08.2008 16:49:52

Hallo zusammen,

brauche mal einen Rat (oder Lösung) von einem Formelspezialisten, der mir evtl. eine Möglichkeit erklärt, wie ich folgendes Prob. lösen kann.

Die Quelldatenblätter, mussen in jedem Quartal gelöscht und wieder neu erstellt werden. Die neuen Quelldatenblätter sind alle Punktgenau die gleichen. Wenn ich die Quellen aber lösche, erscheint logischerweise: z.B.

WENN(ODER(#BEZUG!N3="";#BEZUG!N3=0);"";#BEZUG!N3)

dies bleibt auch so, nachdem ich die neuen Quellen wieder eingefügt habe. Die Ursprungsformeln sind folgende:

WENN(ODER(MA2!N3="";MA2!N3=0);"";MA2!N3) bis WENN(ODER(MA9!N368="";MA9!N368=0);"";MA9!N368)

Bei meinem Versuch, die Formeln händisch einzugeben, ließ die Mappe von 3,5 MB auf 24 MB anschwellen.
Eine Bedingte Formatierung die auch noch enthalten ist, kann ich aber auch nicht weglassen.

Vielleicht kann mir bitte jemand von Euch helfen eine Lösung zu finden, das die Formeln nach dem löschen der Quellen, noch brauchbar sind.

Danke schon mal

Gruß Josef

  

Betrifft: mit INDIREKT von: WF
Geschrieben am: 18.08.2008 17:56:00

Hi Josef,

schreibe:
=WENN(ODER(INDIREKT(K1&"!N3")="";INDIREKT(K1&"!N3")=0);"";INDIREKT(K1&"!N3"))
in K1 steht MA2

Wenn Du jetzt das Blatt MA2 löschst erscheint zwar #BEZUG! - nach Eifügen eines neuen Blattes und dieses dann umgetauft in MA2 ist alles paletti.

Salut WF


  

Betrifft: AW: mit INDIREKT von: Josef_T
Geschrieben am: 18.08.2008 19:14:28

Hallo Walter,

Deine Lösung funktioniert natürlich einwandfrei.

Danke für Deine Hilfe!

Gruß
Josef


 

Beiträge aus den Excel-Beispielen zum Thema "Fehlermeldung #BEZUG evtl. umgehen?"