Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema Image
BildScreenshot zu Image Image-Seite mit Beispielarbeitsmappe aufrufen

Suche Formel oder Makro Lösung | Herbers Excel-Forum


Betrifft: Suche Formel oder Makro Lösung von: Becker
Geschrieben am: 27.10.2008 19:59:36

Hallo liebes Forumsgemeinde...

Meine Suche und auch meine Versuche sind leider fehlgeschlagen.
Ich suche eine (für mich leider komplizierte) Summen Lösung mit mehreren
Kriterien.
Welche Formel oder Makro das lösen konnte??
In Mappe1 habe ich meine Frage ausführlicher anhand der Beispiel beschrieben.

Wenn jemand eine Lösung dafür weiß, würde ich um Hilfe bitten.

Hier meine Tabelle1;
https://www.herber.de/bbs/user/56330.xls

Kann mir jemand Tipps geben?

Netten Gruß
Daniel

  

Betrifft: AW: Suche Formel oder Makro Lösung von: Klaus-Dieter
Geschrieben am: 27.10.2008 20:18:47

Hallo Daniel,

klarer Fall: Summenprodukt.

Tabelle1

 WXYZAA
1ArtikNr aus Spalte DEURO-SUMCHF-SUMUSD-SUMSKK-SUM
2222252,00 €CHF 5,00118,00 USD12,00 SKK
32020 CHF 54,00  
4111165,00 € 112,00 USD 

Formeln der Tabelle
ZelleFormel
X2=SUMMENPRODUKT(($D$2:$D$30=$W2)*($G$2:$G$30="EUR")*($O$2:$O$30))
Y2=SUMMENPRODUKT(($D$2:$D$30=$W2)*($G$2:$G$30="CHF")*($O$2:$O$30))
Z2=SUMMENPRODUKT(($D$2:$D$30=$W2)*($G$2:$G$30="USD")*($O$2:$O$30))
AA2=SUMMENPRODUKT(($D$2:$D$30=$W2)*($G$2:$G$30="SKK")*($O$2:$O$30))
X3=SUMMENPRODUKT(($D$2:$D$30=$W3)*($G$2:$G$30="EUR")*($O$2:$O$30))
Y3=SUMMENPRODUKT(($D$2:$D$30=$W3)*($G$2:$G$30="CHF")*($O$2:$O$30))
Z3=SUMMENPRODUKT(($D$2:$D$30=$W3)*($G$2:$G$30="USD")*($O$2:$O$30))
AA3=SUMMENPRODUKT(($D$2:$D$30=$W3)*($G$2:$G$30="SKK")*($O$2:$O$30))
X4=SUMMENPRODUKT(($D$2:$D$30=$W4)*($G$2:$G$30="EUR")*($O$2:$O$30))
Y4=SUMMENPRODUKT(($D$2:$D$30=$W4)*($G$2:$G$30="CHF")*($O$2:$O$30))
Z4=SUMMENPRODUKT(($D$2:$D$30=$W4)*($G$2:$G$30="USD")*($O$2:$O$30))
AA4=SUMMENPRODUKT(($D$2:$D$30=$W4)*($G$2:$G$30="SKK")*($O$2:$O$30))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Viele Grüße Klaus-Dieter

Klaus-Dieter's Excel und VBA Seite
Online-Excel



  

Betrifft: AW: SUMMENPRODUKT von: Erich G.
Geschrieben am: 27.10.2008 20:20:09

Hallo Daniel,
das geht so Formel nach rechts und unten kopieren - Formate dabei nicht überschreiben):

 WXYZAA
1ArtikNr aus Spalte DEURO-SUMCHF-SUMUSD-SUMSKK-SUM
2222252,00 €CHF 5,00118,00 USD12,00 SKK
320200,00 €CHF 54,000,00 USD0,00 SKK
4111165,00 €CHF 0,00112,00 USD0,00 SKK

Formeln der Tabelle
ZelleFormel
X2=SUMMENPRODUKT(($D$2:$D$30=$W2)*($G$2:$G$30=LINKS(X$1;3))*$O$2:$O$30)

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: SUMMENPRODUKT-Letzte Frage von: Becker
Geschrieben am: 27.10.2008 20:45:15

Hallo liebe Profis,

WAU WAU WAU Echt Klasse, SUPPPEEEERRRRRR!
"1000000 Dank an Profi Erich aus Kamp-Linford"
"1000000 Dank an Meister Klaus-Dieter"


Hätte noch eine Frage zu mein angesprochenes Problem;

Gibt es noch eine Möglichkeit wie man ab Spalte "W2" alle ArtikNr ab Spalte "D2" auslesen kann??
Ich habe nur ein Teil der Tabelle als Beispiel genommen. Die Daten sind mind. 80 Zeilen belegt, so müste man manuell die ArtikNr aus "D2" ins bzw. ab "W2" eingeben damit man den gewünschten Ergebniss bekommt.

Für jede Hilfe bin ich sehr dankbar

Ihr seit wirkliche Profis und Kenner.
Vielen vielen Dank

Gruß Daniel


  

Betrifft: AW: SUMMENPRODUKT-Letzte Frage von: Klaus-Dieter
Geschrieben am: 27.10.2008 21:16:49

Hallo Daniel,

das kannst du mit dem Spezialfilter machen.

Viele Grüße Klaus-Dieter

Klaus-Dieter's Excel und VBA Seite
Online-Excel



  

Betrifft: AW: SUMMENPRODUKT-Letzte Frage von: Erich G.
Geschrieben am: 28.10.2008 01:09:37

Hi Daniel,
oder mit Formeln ( à la http://www.excelformeln.de/formeln.html?welcher=194 ):

 WXYZAA
1ArtikNr aus Spalte DEURO-SUMCHF-SUMUSD-SUMSKK-SUM
2222252,00 €CHF 5,00118,00 USD12,00 SKK
320200,00 €CHF 54,000,00 USD0,00 SKK
4111165,00 €CHF 0,00112,00 USD0,00 SKK
5252548,00 €CHF 0,000,00 USD0,00 SKK
6313165,00 €CHF 0,000,00 USD0,00 SKK
75558,00 €CHF 4,000,00 USD0,00 SKK
877742,00 €CHF 0,000,00 USD0,00 SKK
96665,00 €CHF 58,000,00 USD0,00 SKK
10141442,00 €CHF 0,000,00 USD0,00 SKK
11888987,00 €CHF 0,000,00 USD0,00 SKK
122424546,00 €CHF 0,000,00 USD0,00 SKK
1321210,00 €CHF 25,0056,00 USD98,00 SKK
14333654,00 €CHF 0,000,00 USD0,00 SKK
1528280,00 €CHF 0,000,00 USD0,00 SKK
161010987,00 €CHF 0,000,00 USD0,00 SKK
179996,00 €CHF 0,000,00 USD0,00 SKK
1827272.587,00 €CHF 0,000,00 USD0,00 SKK
19     

Formeln der Tabelle
ZelleFormel
W2=D2
X2=WENN(W2="";"";SUMMENPRODUKT(($D$2:$D$30=$W2)*($G$2:$G$30=LINKS(X$1;3))*$O$2:$O$30))
W3{=INDEX(D:D;1+VERGLEICH(1;(ZÄHLENWENN(W$2:W2;D$2:D$100)=0)*(D$2:D$100<>""); 0))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

(Formeln von W3 nach unten kopieren)

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: SUMMENPRODUKT-Letzte Frage von: Becker
Geschrieben am: 28.10.2008 19:28:26

Halo Erich,
Hallo Klaus-Dietr,

Danke Dir Klaus für den Filter Tipp.
Die Lösung von Erich passt mir viel besser.
Dank Dir Erich und Deiner prof. Hilfe/Beratung und Erfahrung habe ich die Ehre so eine spezielle Formel zu kennenlernen.
Tausend mal Danke Dir und Danke auch an Klaus-Dieter.
Netten Gruß Daniel


Beiträge aus den Excel-Beispielen zum Thema "Suche Formel oder Makro Lösung"