Microsoft Excel

Herbers Excel/VBA-Archiv

Daten holen aus anderen Tabellenblättern

Betrifft: Daten holen aus anderen Tabellenblättern von: Albin
Geschrieben am: 11.08.2008 18:57:30

Hallo miteinander

Ich habe ein kleines grosses Problem. Muss bis ende Woche das Problem gelöst haben und ich weiss einfach nicht weiter.

In Tabelle 9000 Zelle I15 hab ich folgende Formel:
=SUMMEWENN('m-9000'!$G$1:$G$1869;B15;'m-9000'!$R$1:$R$1869)

Das heisst, ich gehe mit dieser Formel Daten holen in der Tabelle m-9000. Jetzt möchte ich aber Daten aus vielen verschiedenen Tabellenblättern holen (viele mehr als in der Beispieldatei enthalten). Und weil ich sehr viele Zeilen und Tabellen habe mit dieser Formel, möchte ich diese Formeln nicht immer wieder manuell ändern müssen. Kopieren kann ich sie nicht, da dazwischen immer wieder Leerzeilen vorhanden sind (müssen).

Ich dachte nun, dass ich beispielsweise in der Spalte "L" vielleicht 10 Tabellennamen auflisten kann, und mit den Namen eine Verknüpfung zu der jeweiligen Tabelle herstellen kann. Wie kann ich das nun machen? 'm-9000'! irgendwie ersetzen und ergänzen mit einer WENN-Formel? Das übersteigt einfach meine Kenntnisse!

Link zur Datei: https://www.herber.de/bbs/user/54523.xls

Vielen Dank im voraus für eure Hilfe!
Lieber Gruss
Albin

  

Betrifft: AW: Daten holen aus anderen Tabellenblättern von: Tino
Geschrieben am: 11.08.2008 21:21:47

Hallo,
hier mal ein Beispiel für deine Zelle i16.
Wird aber recht unübersichtlich.

 I
16              5

Formeln der Tabelle
ZelleFormel
I16=SUMMEWENN(INDIREKT("'"&$L$1&"'!$G$1:$G$1869"); B16;INDIREKT("'"&$L$1&"'!$R$1:$R$1869"))+SUMMEWENN(INDIREKT("'"&$L$2&"'!$G$1:$G$1869"); B16;INDIREKT("'"&$L$2&"'!$R$1:$R$1869"))+SUMMEWENN(INDIREKT("'"&$L$3&"'!$G$1:$G$1869"); B16;INDIREKT("'"&$L$3&"'!$R$1:$R$1869"))+SUMMEWENN(INDIREKT("'"&$L$4&"'!$G$1:$G$1869"); B16;INDIREKT("'"&$L$4&"'!$R$1:$R$1869"))+SUMMEWENN(INDIREKT("'"&$L$5&"'!$G$1:$G$1869"); B16;INDIREKT("'"&$L$5&"'!$R$1:$R$1869"))


PS: warum hast du noch mal einen Beitrag angefangen?

Gruß Tino


 

Beiträge aus den Excel-Beispielen zum Thema "Daten holen aus anderen Tabellenblättern"