Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Vergleich mit Werten aus Tabellen mit Wenn-Bedingu

Vergleich mit Werten aus Tabellen mit Wenn-Bedingu
Kai
Guten Morgen,
ich habe folgendes Problem: Ich habe zwei Preislisten welche mehrere hundert Artikel umfassen. Liste A ist eine Gesamtpreisliste. Liste B ist eine Liste, die unser Kunde mir zwecks Aktualisierung zuschickt. Nun möchte ich in Liste B, dass ich über eine Wenn-Formel die Artikelnummern abgleichen und wenn diese dann gefunden werden, der entsprechende Kundenpreis aus Liste A in Liste B angezeigt wird. In der Liste A stehen in Spalte A die Artikelnummern und in Spalte S die dazugehörigen Preise.
Ein weiteres Problem ist, dass ich in Liste B (also der Kundenliste) zum einen nicht nach Artikelnummer sortieren kann und zum anderen dort keine Makros einbauen darf. Ich hatte es schon einmal mit der Formel
=WENN(ISTFEHLER(VERGLEICH(A2;'[Liste A.xls]Artikel'!$A$2:$A$188;0));"fehlt"; '[Liste A.xls]Artikel'!$S$2:$S$188)
versucht, aber die Werte die mir dann ausgegeben werden, stimmen nicht. Ist sowas machbar?
Ich habe einmal eine Beispieldatei angehängt in der Hoffnung, dass mein Anliegen es etwas deutlicher wird.
https://www.herber.de/bbs/user/65580.xls
Ich danke euch schon mal im Voraus.
Viele Grüße
Kai

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Vergleich mit Werten aus Tabellen mit Wenn-Bedingu
04.11.2009 10:00:22
David
Hallo Kai,
so?
=WENN(ISTFEHLER(SVERWEIS(A2;'Liste A'!$A$2:$S$5;19;0));"n.v.";SVERWEIS(A2;'Liste A'!$A$2:$S$5;19;0))
(in F2 von Liste B und dann runterkopieren)
Gruß
David
AW: Vergleich mit Werten aus Tabellen mit Wenn-Bedingu
04.11.2009 10:13:50
Kai
Hallo David,
danke für deine rasche Antwort. Formel passt soweit.
Gruß
Kai
=SVERWEIS(A2;'Liste A'!A:S;19;) owT
04.11.2009 10:01:11
Rudi
Anzeige

323 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige