Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Werte aus Datenbank auslesen

Werte aus Datenbank auslesen
17.03.2009 08:05:59
Klaus-Dieter
Hallo zusammen,
kann mir jemand bitte bei nachfolgendem Beispiel weiterhelfen. Ich habe verschiedene Datenbank aus der ich über sverweis verschiedene Daten auslese.
In einer weiteren Datenbank habe ich das Problem daß der Wert in Spalte A öfters vorhanden ist. Mit SVerweis komme ich aber immer nur in die erste Zeile. Ich sollte aber die Merkmalstexte suchen und die Werte in der Spalte Ausprägung anzeigen will.
Gibt es eine Möglichkeit in der ich zuerst den einen Wert suche (im Bsp. 305013) und dann nach einem weiteren Wert suche und diesen anzeigen kann?
https://www.herber.de/bbs/user/60375.xlsx
Für eure Hilfe vielen Dank
Klaus-Dieter

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Werte aus Datenbank auslesen
17.03.2009 08:51:45
Tino
Hallo,
meinst Du sowas?
 ABCDEFGHI
2     Suchwert   
3     305013   
4 MERKMALMERKMALTXTAUSPRAEGUNG  MERKMALMERKMALTXTAUSPRAEGUNG
5305013MERKMAL 1ISOLIERPLATTENEIN 305013MERKMAL 1ISOLIERPLATTENEIN
6305013MERKMAL 10AUFSPANNMÖGLICHKEITPRATZEN 305013MERKMAL 10AUFSPANNMÖGLICHKEITPRATZEN
7305013MERKMAL 11HEIZUNGWASSER 305013MERKMAL 11HEIZUNGWASSER
8305013MERKMAL 12DATUMSUHRNEIN 305013MERKMAL 12DATUMSUHRNEIN
9         

Formeln der Tabelle
ZelleFormel
F5{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A1))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A1)); SPALTE(B$1)-1))}
G5{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A1))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A1)); SPALTE(C$1)-1))}
H5{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A1))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A1)); SPALTE(D$1)-1))}
I5{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A1))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A1)); SPALTE(E$1)-1))}
F6{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A2))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A2)); SPALTE(B$1)-1))}
G6{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A2))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A2)); SPALTE(C$1)-1))}
H6{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A2))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A2)); SPALTE(D$1)-1))}
I6{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A2))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A2)); SPALTE(E$1)-1))}
F7{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A3))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A3)); SPALTE(B$1)-1))}
G7{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A3))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A3)); SPALTE(C$1)-1))}
H7{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A3))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A3)); SPALTE(D$1)-1))}
I7{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A3))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A3)); SPALTE(E$1)-1))}
F8{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A4))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A4)); SPALTE(B$1)-1))}
G8{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A4))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A4)); SPALTE(C$1)-1))}
H8{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A4))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A4)); SPALTE(D$1)-1))}
I8{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A4))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A4)); SPALTE(E$1)-1))}
F9{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A5))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A5)); SPALTE(B$1)-1))}
G9{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A5))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A5)); SPALTE(C$1)-1))}
H9{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A5))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A5)); SPALTE(D$1)-1))}
I9{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A5))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A5)); SPALTE(E$1)-1))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Gruß Tino
Anzeige
AW: Werte aus Datenbank auslesen
17.03.2009 09:05:58
Tino
Hallo,
so ist es besser, brauchen so nicht hinten -1 zu machen.
 ABCDEFGHI
1         
2     Suchwert   
3     305013   
4 MERKMALMERKMALTXTAUSPRAEGUNG  MERKMALMERKMALTXTAUSPRAEGUNG
5305013MERKMAL 1ISOLIERPLATTENEIN 305013MERKMAL 1ISOLIERPLATTENEIN
6305013MERKMAL 10AUFSPANNMÖGLICHKEITPRATZEN     
7305013MERKMAL 11HEIZUNGWASSER     
8305013MERKMAL 12DATUMSUHRNEIN     

Formeln der Tabelle
ZelleFormel
F5{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A1))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A1)); SPALTE(A$1)))}
G5{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A1))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A1)); SPALTE(B$1)))}
H5{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A1))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A1)); SPALTE(C$1)))}
I5{=WENN(ISTFEHLER(KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A1))); "";INDEX($A:$D;KKLEINSTE(WENN($A$5:$A$100=$F$3;ZEILE($A$5:$A$100)); ZEILE($A1)); SPALTE(D$1)))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Gruß Tino
Anzeige
AW: Werte aus Datenbank auslesen
17.03.2009 09:13:49
Klaus-Dieter
Hallo Tino,
ich habe eine Tabelle und suche mit dem Wert z.B. 305013 verschiedene Datenbanken durch um Felder auszulesen.
Ein Feld heißt z.b. Aufspannmöglichkeit. Nun benötige ich den zugehörigen Wert (in diesem Fall "Pratzen")
Grüße
Klaus-Dieter
AW: Werte aus Datenbank auslesen
17.03.2009 09:30:44
Klaus-Dieter
Hallo Tino,
hat funktioniert.
Vielen Dank für deine Hilfe.
Grüsse
Klaus-Dieter
AW: Werte aus Datenbank auslesen
17.03.2009 09:33:33
Tino
Hallo,
meinst Du so?
 ABCDEFG
3     NrMERKMALTXT
4 MERKMALMERKMALTXTAUSPRAEGUNG 305013AUFSPANNMÖGLICHKEIT
5305013MERKMAL 1ISOLIERPLATTENEIN   
6305013MERKMAL 10AUFSPANNMÖGLICHKEITPRATZEN Suchergebnis 
7305013MERKMAL 11HEIZUNGWASSER PRATZEN 
8305015MERKMAL 12DATUMSUHRNEIN   

Formeln der Tabelle
ZelleFormel
F7=VERWEIS(2;1/(A1:A100&C1:C100=F4&G4); D1:D100)

Gruß Tino
Anzeige
AW: Werte aus Datenbank auslesen
17.03.2009 09:52:02
Klaus-Dieter
Hallo Tino,
die Formel ist denke ich für mich einfacher.
Habe sie in meine Datenbank eingebaut und sie funktioniert. Nochmals vielen Dank für deine Hilfe und einen schönen Tag.
Gruss
Klaus-Dieter

361 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige