Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Werte aus Matrix auslesen

Werte aus Matrix auslesen
01.10.2013 13:25:36
Mekerde
Hallo,
ich stoße mit meinen Excel-Kenntnissen an meine Grenzen. Ich habe eine Tabelle gefüllt mit KW/JJ. Diese Tabelle gibt aus, welche Variante wann, zu welchen Typ eingesetzt wird. Ich möchte gerne das kleinste Datum (KW/JJ) in eine Extra-Spalte schreiben lassen.
Ich habe eine Formel, um den ersten Wert in der Zeile in einer Extra-Zeile auszugeben, jedoch bekomme ich dies nicht angepasst.
Formel:
=WENN(MIN(WENN(ISTTEXT($B2:$E2);SPALTE($B2:$E2)))>3;INDEX(B2:E2;1;MIN(WENN(ISTTEXT($B2:$E2); SPALTE($B2:$E2)))-2);"")
Var Typ1 Typ2 Typ3 Typ4
______________________________________
Var1 43/14 12/15
Var2 12/15 23/14 36/13
Var3 11/16
Var4 36/15 26/15
Vielen Dank im Voraus,
Mekerde

1
Beitrag zum Forumthread
Beitrag zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Werte aus Matrix auslesen
01.10.2013 15:56:24
fcs
Hallo Mekerde,
Die Ziffernfolge KW/JJ ist leider etwas mühselig auszuwerten, da für eine Minimum-Auswertung das Ganze erst in die Reihenfolge JJKW gebracht und nummerisch gemacht werden muss.
mfg
Franz
Tabelle2

 ABCDEFG
1VarTyp1Typ2Typ3Typ4Min JJ/KWMin
2       
3Var143/1412/15  14/4343/14
4Var212/1523/1436/13 13/3636/13
5Var311/16   16/1111/16
6Var436/1526/15  15/2626/15

Formeln der Tabelle
ZelleFormel
F3{=TEXT(MIN(WENN(B3:E3<>"";WERT(TEIL(B3:E3;SUCHEN("/";B3:E3;1)+1;2))*100+WERT(LINKS(B3:E3;SUCHEN("/";B3:E3;1)-1)); 9999)); "00""/""00")}
G3=TEIL(F3;4;2)&"/"&LINKS(F3;2)
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Anzeige

355 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige