Microsoft Excel

Herbers Excel/VBA-Archiv

Werte suchen/finden/kennzeichnen | Herbers Excel-Forum


Betrifft: Werte suchen/finden/kennzeichnen von: Karsten
Geschrieben am: 27.01.2012 20:20:14

Hallo werte Gemeinde,

nachdem ich nun mehrere Stunden probiert habe stelle ich nun euch die Frage.

Ich habe in der Tabelle in Spalte e mehrer Werte untereinander stehen (z.b. ADV100, ADV101 etc. geht bis ADV999).

Schrittweise werden in Spalte c Werte eingefügt (z.B. ADV100). Nun soll eine Formel dazu helfen, dass erkannt wird, dass es diesen Wert bereits in Spalte e gibt. Wenn er gefunden wurde soll dieser quasi
in spalte e markiert werden oder z.b. in einer neuen Spalte und der jeweiligen Zeile ein Zeichen gesetzt werden. Wenn er diesen Wert nicht findet, soll ebenfalls eine Markierung erfolgen oder ein anderes Zeichen in der neuen Spalte gesetzt werden. Sprich bei einer noch nicht befüllten Tabelle würde dann zunächst überall noch das Fehltzeichen stehen.

Ziel ist es zu prüfen, ob sich letzendlich alle Werte wiederfinden, die in e eingetragen wurden bzw. noch einer fehlt.
Gruß
Karsten

  

Betrifft: AW: Werte suchen/finden/kennzeichnen von: Uwe (:o)
Geschrieben am: 27.01.2012 20:57:38

Hallo Karsten,
das sollte sich doch ganz einfach durch ZÄHLENWENN lösen lassen.
Also z.B.
=WENN(ZÄHLENWENN(C:C;E1)>0;"X";"-")
oder die entsprechende Formel in einer Bedingten Formatierung.
Oder habe ich Dich falsch verstanden?

Gruß
Uwe
(:o)


  

Betrifft: AW: Werte suchen/finden/kennzeichnen von: Karsten
Geschrieben am: 27.01.2012 22:44:01

Zunächst dank an Uwe,
sind auf richtigen Weg.
Funktioniert aber nur teilweise.

Habe die Formel so angewendet. Steht ja nun in Zeile 1.
Allerdings wenn ich die Spalte wo der Dann und Sonst Wert steht nach unten ausfüllen will, oder die Formel einfüge, verschiebt sich automatisch der Wert erste C Wert jeweils auf die aktuelle Zeile. Also C2, C3, C4 ,C5 etc., sodass dann die oberen Werte nicht mehr gefunden werden.

Dazu brauche ich noch eine Idee.

Gruß Karsten


  

Betrifft: AW: Werte suchen/finden/kennzeichnen von: Karsten
Geschrieben am: 27.01.2012 22:51:55

Vielen Dank nochmals an Uwe,

habe Problem lösen können, einfach im dem $ Zeichen den Feldbezug definieren und schon geht es.

Besten Dank


  

Betrifft: AW: Werte suchen/finden/kennzeichnen von: Uwe (:o)
Geschrieben am: 28.01.2012 13:05:03

Hallo Karsten,
wenn Du als Bereich C:C angegeben hast, wie in meinem Vorschlag ist auch kein $, sprich absoluter Bezug notwendig, bei $C$1:$C$100 natürlich schon.
Aber Du hast es ja selbst gefunden.
Freut mich.

Gruß
Uwe
(:o)