Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Werte aus Matrix neu ordnen (transformieren)

Werte aus Matrix neu ordnen (transformieren)
Michael
Hallo,
ich habe ein Problem, welches ich bereits über eine Pivottabelle zu lösen versuchte, vergebens.
Die folgende Tabelle möchte ich wie folgt umstrukturieren:
ALT
Nummer Jahr Wert
001-0001 2007 29.000.000,00
001-0001 2008 28.900.000,00
001-0001 2009 28.900.000,00
001-0002 2007 26.080.000,00
001-0002 2008 25.970.000,00
001-0003 2007 6.700.000,00
001-0003 2008 6.600.000,00
001-0003 2009 6.310.000,00
NEU
Nummer 2007 2008 2009
001-0001 29.000.000 28.900.000 28.900.000
001-0002 26.080.000 25.970.000
001-0003 6.700.000 6.600.000 6.310.000
Wie krieg ich das nur hin?
Über Tipps bin ich sehr, sehr dankbar !!!
Vielen Dank im voraus
Michael

1
Beitrag zum Forumthread
Beitrag zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Werte aus Matrix neu ordnen (transformieren)
24.07.2009 22:52:41
Josef
Hallo Michael,
Exelformeln.de
Tabelle1

 ABCDEFGHI
1NummerJahrWert  Nummer200720082009
2001-0001200729.000.000,00  001-000129.000.00028.900.00028.900.000
3001-0001200828.900.000,00  001-000226.080.00025.970.000 
4001-0001200928.900.000,00  001-00036.700.0006.600.0006.310.000
5001-0002200726.080.000,00      
6001-0002200825.970.000,00      
7001-000320076.700.000,00      
8001-000320086.600.000,00      
9001-000320096.310.000,00      

Formeln der Tabelle
ZelleFormel
F2=A2
G2{=WENN(UND($F2<>"";SUMMENPRODUKT(($A$2:$A$99=$F2)*($B$2:$B$99=G$1))>0); INDEX($C$2:$C$99;MIN(WENN(($A$2:$A$99=$F2)*($B$2:$B$99=G$1); ZEILE($1:$98)))); "")}
F3{=WENN(SUMME(ZÄHLENWENN(A$2:A$99;F$2:F2))>=SUMME((A$2:A$99<>"")*1); "";INDEX(A$2:A$99;VERGLEICH(1;(ZÄHLENWENN(F$2:F2;A$2:A$99)=0)*(A$2:A$99<>""); 0)))}
G3{=WENN(UND($F3<>"";SUMMENPRODUKT(($A$2:$A$99=$F3)*($B$2:$B$99=G$1))>0); INDEX($C$2:$C$99;MIN(WENN(($A$2:$A$99=$F3)*($B$2:$B$99=G$1); ZEILE($1:$98)))); "")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Sepp

Anzeige

319 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige