Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema ListBox
BildScreenshot zu ListBox ListBox-Seite mit Beispielarbeitsmappe aufrufen

Aus einer Matrix einen bestimmten Zellwert finden

Betrifft: Aus einer Matrix einen bestimmten Zellwert finden von: erichm
Geschrieben am: 01.11.2014 12:29:14

Hallo,

ich benötige dafür Hilfe:
1. für Lösung in C5: Suche die Zahl aus der Zelle B3 (=10) in der Spalte J und ermittle aus der Zeile in Spalte I das Datum, bei dem die Zahl 10 in der untersten Zeile vorhanden ist = Zeile 10.
2. für Lösung in C6: Suche die Zahl aus der Zelle B3 (=10) in der Spalte K und ermittle aus der Zeile in Spalte I das Datum, bei dem die Zahl 10 in der untersten Zeile vorhanden ist.
usw...
Das gleiche gilt für die Zahl 15 dann.

Testkontrolle (2)

 ABCDEFGHIJKL
1            
2            
3 10 15   Varianten  
4VarianteAnzzuletztLösungAnzzuletztLösung DatumABC
5A2Datum??01.02.20141Datum??11.01.2014 06.01.201410201
6B1Datum??01.02.20142Datum??21.01.2014 08.01.2014101887
7C1Datum??11.01.20141Datum??26.01.2014 11.01.2014151510
8        21.01.201401520
9        26.01.201418413415
10        01.02.2014101020

Formeln der Tabelle
ZelleFormel
B5=ZÄHLENWENN(J$5:J$10;B$3)
E5=ZÄHLENWENN(J$5:J$10;E$3)
B6=ZÄHLENWENN(K$5:K$10;B$3)
E6=ZÄHLENWENN(K$5:K$10;E$3)
B7=ZÄHLENWENN(L$5:L$10;B$3)
E7=ZÄHLENWENN(L$5:L$10;E$3)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

DANKE!
mfg

  

Betrifft: AW: Aus einer Matrix einen bestimmten Zellwert finden von: Rudi Maintaire
Geschrieben am: 01.11.2014 12:58:28

Hallo,
ich bau das nicht nach.
Vermutlich
=verweis(2;1/(J:J=B3);I:I)

Gruß
Rudi


  

Betrifft: AW: Aus einer Matrix einen bestimmten Zellwert finden von: erichm
Geschrieben am: 01.11.2014 13:11:43

Nicht nur vermutlich: das passt PERFEKT - DANKE!!

Da wäre ich nie drauf gekommen :)


  

Betrifft: Wenn Rudis Formel für alle relevanten Zellen ... von: Luc:-?
Geschrieben am: 01.11.2014 14:20:59

…gelten soll, Erich,
kannst du sie auch wie folgt erweitern:
C5[:C7;F5:F7]:=VERWEIS(2;1/(INDEX($J$5:$L$10;0;VERGLEICH($A5;$J$4:$L$4;0))=B$3);$I$5:$I$10)
Dadurch kannst du, sie von C5 ausgehend, in jede andere Ergebnis­Zelle deines Bsps einfach einkopieren ohne die Adressen anpassen zu müssen.
Gruß, Luc :-?


  

Betrifft: AW: Wenn Rudis Formel für alle relevanten Zellen ... von: erichm
Geschrieben am: 01.11.2014 14:44:51

SUPER - Danke!
Soeben wollte ich eine weitere Frage deswegen einstellen, weil ich die Kopierproblematik lösen wollte. Das habe ich jetzt eine Weile ganz anders versucht.

Nochmals besten Dank für den tollen Service!

mfg


  

Betrifft: Bitte! Als ob ich's mir gedacht hätte... ;-) owT von: Luc:-?
Geschrieben am: 01.11.2014 21:12:56

:-?


 

Beiträge aus den Excel-Beispielen zum Thema "Aus einer Matrix einen bestimmten Zellwert finden"