Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Auswertungen aus Matrix - Wie

Auswertungen aus Matrix - Wie
05.09.2008 12:03:00
trebor-robert
Hallo,
wie kann ich aus einer Matrix, die in einer seperaten Arbeitsmappe liegt, den entsprechenden EUR Betrag auslesen, wenn in der Spalte D untereinander in den einzelnen Zeilen die Bemessungsgrösse 1 steht (in diesem Fall qm) und in den Spalten nebeneinander die Bemessungsgrösse 2 (in diesem Fall Entfernungs KM).
Mit dem Sverweis komme ich hier nämlich nicht weiter oder?
Zur besseren Verdeutlichung habe ich eine Beispielarbeitsmappe beigefügt.
https://www.herber.de/bbs/user/55202.xls
Diese Arbeitsmappe ist nur als Idee zu verstehen, da ich momentan gerade in der Entwicklungsphase eines Datenmodells bin um in Zukunft diese Auswertungen mit geringem Aufwand machen zu können.
Wenn jemand bessere Ideen zur Umsetzung hat bin dafür gerne offen.
Fakt ist, daß die Arbeitmappe mit den Datensätzen, zu denen die Kosten dazugefügt werden sollen vom Aufbau in dieser Art, wie angegeben aussieht und nicht verändert werden kann (d. h. jede Zeile eine neue Tour mit entsprechenden Angaben wie tatsächliche Entfernung, Volumen, KD-Nr usw.)
Wer kann mir hierbei helfen?
Danke.
Trebor-robert

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Auswertungen aus Matrix - Wie
05.09.2008 12:10:00
Mac4
Hi,
das geht mit Summenprodukt, wobei Du dann die Spalte A eigentlich nicht unbedingt brauchst!
=SUMMENPRODUKT(($A$5:$A$15=$B$23&" "&G22)*(G5:G15))*-1
Marc
mit summenprodukt()
05.09.2008 12:18:00
heikoS
Hallo Robert,
das geht z.B. so:
Tabelle1

 G
23-28

Formeln der Tabelle
ZelleFormel
G23=-SUMMENPRODUKT(--($B$5:$B$15=$B23); --($C$5:$C$15=G$22); G5:G15)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Klappt´s?
Gruß Heiko
Anzeige
oder mit summewenn() und Spalte A
05.09.2008 12:25:11
heikoS
Hallo Robert,
sorry, ich hatte Deine Hilfsspalte A übersehen. Die wird dann hilfreich werden, wenn Du viele Datensätze verarbeiten willst, denn die Funktion summenprodukt() bremst die Performance "ein wenig". Durch die Verkettung in A kannst Du summewenn() einsetzen.
Tabelle1

 G
25-28

Formeln der Tabelle
ZelleFormel
G25=-SUMMEWENN(A5:A15;$B23&" "&G$22;G5:G15)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Eine Anmerkung von mir: ich würde in der Verkettung auf das Leerzeichen verzichten, es verursacht nur Tipperei und bringt keine Vorteile, da Du die Übersicht ja in den Spalten B und C hast.
Gruß Heiko
Anzeige

310 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige