Anzeige
Archiv - Navigation
1164to1168
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zelladressee des MAX-Wertes einer Matrix ausgeben

Zelladressee des MAX-Wertes einer Matrix ausgeben
JOWE
(eigentlich fehlt hier das Level 'Excel geht so'
Hallo,
im Bereich A5:A155 befinden sich Ganzzahlwerte im Bereich von 0 - 999.
Werte können doppelt/mehrfach auftreten. Leere Zellen oder Textwerte sind nicht enthalten
Mit der Formel -MAX(A1:A155) finde ich den/die größten Wert(e) aus der Matrix.
Kann ich mit einer Formel die Zelladresse/n oder die Zeilennummer/n ermitteln?
Gruß
Jochen

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Zelladressee des MAX-Wertes einer Matrix ausgeben
15.07.2010 09:13:04
Tino
Hallo,
vielleicht so.
 ABC
10 $A$5
21  
36  
49  
529  
615  
718  
824  

Formeln der Tabelle
ZelleFormel
C1=ADRESSE(VERGLEICH(MAX(A:A); A:A;0); 1)

Gruß Tino
Anzeige
AW: Ja das ist es, danke oT
15.07.2010 09:28:01
JOWE
Zeilen des MAX-Wertes in einer Spalte
15.07.2010 09:13:36
Erich
Hi Jochen,
so?
 AB
14135
21237
3645 
482 
5997 
6162 
7997 
8341 

Formeln der Tabelle
ZelleFormel
B1{=KKLEINSTE(WENN(A$1:A$155=MAX(A$1:A$155); ZEILE($1:$155)); ZEILE())}
B2{=WENN(ZÄHLENWENN(A$1:A$155;MAX(A$1:A$155))<ZEILE(); ""; KKLEINSTE(WENN(A$1:A$155=MAX(A$1:A$155); ZEILE($1:$155)); ZEILE()))}
B3{=WENN(ZÄHLENWENN(A$1:A$155;MAX(A$1:A$155))<ZEILE(); ""; KKLEINSTE(WENN(A$1:A$155=MAX(A$1:A$155); ZEILE($1:$155)); ZEILE()))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort
Anzeige
Dir ebenfalls Danke oT
15.07.2010 09:36:24
JOWE
Adressen des MAX-Wertes in einer Spalte
15.07.2010 09:26:56
Erich
Hi Jochen,
und noch zwei bis drei Varianten: (VERGLEICH habe ich von Tino abgeschaut.)
 ABCD
14135A55
21237A77
36459A99
482   
5997   
6162   
7997   
8341   
9997   
102   

Formeln der Tabelle
ZelleFormel
B1=VERGLEICH(MAX(A:A); A:A;0)
C1="A"&VERGLEICH(MAX(A:A); A:A;0)
D1{=MIN(WENN(A$1:A$155=MAX(A$1:A$155); ZEILE($1:$155)))}
B2=WENN(ZÄHLENWENN(A$1:A$155;MAX(A$1:A$155))<ZEILE(); ""; B1+VERGLEICH(MAX(A:A); INDEX(A:A;B1+1):INDEX(A:A;9999); 0))
C2="A"&WENN(ZÄHLENWENN(A$1:A$155;MAX(A$1:A$155))<ZEILE(); ""; TEIL(C1;2;5)+VERGLEICH(MAX(A:A); INDEX(A:A;TEIL(C1;2;5)+1):INDEX(A:A;9999); 0))
D2{=WENN(ZÄHLENWENN(A$1:A$155;MAX(A$1:A$155))<ZEILE(); ""; KKLEINSTE(WENN(A$1:A$155=MAX(A$1:A$155); ZEILE($1:$155)); ZEILE()))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort
Anzeige
Das war ein wenig Unfug
15.07.2010 09:34:28
Erich
Hi,
statt INDEX(A:A;9999) schreibt man doch besser gleich A$9999...
 ABC
14135A5
21237A7
36459A9
482  
5997  
6162  
7997  
8341  
9997  
102  

Formeln der Tabelle
ZelleFormel
B1=VERGLEICH(MAX(A:A); A:A;0)
C1="A"&VERGLEICH(MAX(A:A); A:A;0)
B2=WENN(ZÄHLENWENN(A$1:A$155;MAX(A$1:A$155))<ZEILE(); ""; B1+VERGLEICH(MAX(A:A); INDEX(A:A;B1+1):A$9999;0))
C2="A"&WENN(ZÄHLENWENN(A$1:A$155;MAX(A$1:A$155))<ZEILE(); ""; TEIL(C1;2;5)+VERGLEICH(MAX(A:A); INDEX(A:A;TEIL(C1;2;5)+1):A$9999;0))

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort
Anzeige
AW: Das war ein wenig Unfug
15.07.2010 19:03:02
JoWE
Hallo Erich,
habe alles mal durchprobiert und mir "gut beiseite gelegt".
Echt Klasse, danke Dir.
Gruß
Jochen

321 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige