Das Archiv des Excel-Forums

Auswertung einer Matrix

Bild

Betrifft: Auswertung einer Matrix
von: Hendrik

Geschrieben am: 02.10.2003 11:57:03

Hallo,

ich habe ein Problem mit der Auswertung einer Matrix.
So sieht die Tabelle in etwa aus:

A B C D E F G
1 x x x x
2 x x x x x
3 x
4 x x x x x

In Spalte G soll ein `x´ geschrieben werden, wenn in den Spalten A:F ein `x´ vorkommt. Wenn in der Zeile kein `x´ vorkommt soll die entsprechende Zelle in Spalte G leer bleiben.

Hat jemand eine Lösung für diese Aufgabenstellung?

Vielen Dank.

Gruß
Hendrik
Bild


Betrifft: AW: Auswertung einer Matrix
von: Panicman
Geschrieben am: 02.10.2003 12:01:19

Hallo Hendrik,

versuchs mal hiermit
=WENN(ZÄHLENWENN(A1:F1;"x")=0;"";"x")
und runterkopieren

Gruß
Holger


Bild


Betrifft: AW: Auswertung einer Matrix
von: Hendrik
Geschrieben am: 02.10.2003 12:04:30

Hallo Holger,

vielen Dank, das hat geklappt.
Echt super.

Gruß
Hendrik


Bild


Betrifft: AW: Auswertung einer Matrix
von: Boris
Geschrieben am: 02.10.2003 12:02:49

Hi Hendrik,

in G1 (und dann runterkopieren):
=WENN(ZÄHLENWENN(A1:F1;"x");"x";"")

Grüße Boris


Bild


Betrifft: Bedingung in Wenn Formel
von: Jörg Gradert
Geschrieben am: 02.10.2003 12:30:53

Hallo Boris,
WENN(0;FALSCH;WAHR)
kannte ich noch nicht.
Habe bisher immer WENN(Bedingung=irgendwas;... geschrieben
schöne Verbesserung.

Gruss Jörg


 Bild

Excel-Beispiele zum Thema " Auswertung einer Matrix"

Wahlauswertung nach Hare-Niemeyer download Entfernungsmatrix listen download
Ausgabe einer benutzerdefinierten Funktion in Matrixformel download Werte aus Zellbereich in eine Matrix übernehmen und auslesen download
Portokosten aus einer Gewichts-/Gebietsmatrix errechnen download Matrix in UserForm-ListBox einlesen download
SVERWEIS-, WVERWEIS- und Matrixformel-Beispiele download Anzahl nach 2 Kriterien ermitteln mit DB-Funktion und MatrixFormel download
Werte aus Matrix in zweitem Blatt auflisten download Zweidimensionale Matrix mit der SVERWEIS-Funktion durchsuchen download
Daten in Matrix indizieren download Temporärer VBA-Einsatz einer Matrixformel download
Ausflugszeiten aus einer Reisematrix ermitteln download Eintragen von Matrixformeln in eine Jahres-/Monatsmatrix download
Werte in Monats/Namen-Ergebnismatrix übernehmen download Preisermittlung aus Artikel-/Kundenmatrix download
Benutzerdefinierte Funktion als Matrixformel download Matrixfunktion über VBA eintragen, auslesen und löschen download
Eine Zusammenstellung von Matrix-Funktionen download