Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema ListBox
BildScreenshot zu ListBox ListBox-Seite mit Beispielarbeitsmappe aufrufen

Worksheetfunction für einen Teil einer Matrix | Herbers Excel-Forum


Betrifft: Worksheetfunction für einen Teil einer Matrix von: Matthias
Geschrieben am: 12.11.2009 13:26:12

Hallo,

ich habe eine eindimensionsale Matrix mit Werten z.B. mit 100 gefüllt. Nun möchte ich eine Worksheetfunction (SDev) für einen Teil, z.B. die ersten 30 Matrixwerte, nutzen.

Gibt es eine Möglichkeit dies zu realisieren.

Vielen Dank.

Matthias

  

Betrifft: AW: Worksheetfunction für einen Teil einer Matrix von: fcs
Geschrieben am: 13.11.2009 02:26:08

Hallo Mathias,

die Funktion "sDev" gibt es bei mir nicht weder als Tabellenfunktion (deutsches Excel) noch als VBA-Funktion.

Gruß
Franz

hier mal ein Beispiel für andere Tabellenfunktionen. In Zelle B1 steht die Anzahl der aus der Datenmatrix zu benutzenden Zeilen.

Tabellenblattname: Tabelle2

    A       B        
1  1            5   
2  2           15   
3  3   1,58113883   
4  4                
5  5                
6  6                
7  7                
8  8                
9  9                

Benutzte Formeln:
B2:  =SUMME(BEREICH.VERSCHIEBEN(DatenMatrix;0;0;B1;1))
B3:  =STABW(BEREICH.VERSCHIEBEN(DatenMatrix;0;0;B1;1))

Namen in der Tabelle:
DatenMatrix             :  =Tabelle2!$A$1:$A$9



Beiträge aus den Excel-Beispielen zum Thema "Worksheetfunction für einen Teil einer Matrix"