Live-Forum - Die aktuellen Beiträge
Datum
Titel
15.07.2024 16:00:57
15.07.2024 15:41:38
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Kombination aus Datum und Schicht Wert finden

Kombination aus Datum und Schicht Wert finden
Karl
Hallo allerseits
Ich möchte wenn mein Arbeitstag ein Feiertag ist
den entsprechenden Wert dazu aus der Feiertagsliste
in Spalte Zulage eintragen
Beispiel: am 02.06. T (Tagdienst) soll der Wert 8 in Spalte Zulage stehen
Am 23.06. S (Spätdienst) soll dort der Wert 9 stehen
Mit den Beispielen von Excelformel komm ich gar nicht klar
Kann mir hier jemand bitte helfen
https://www.herber.de/bbs/user/75283.xls
Danke Karl

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Kombination aus Datum und Schicht Wert finden
13.06.2011 14:59:33
Uwe
Hallo Karl,
teste mal in S4 (und runterkopieren):
=WENN(ISTFEHLER(INDEX($AA$4:$AB$13;VERGLEICH(A4;$Z$4:$Z$13;0);(C4="T")*1+(C4="S")*2));""; INDEX($AA$4:$AB$13;VERGLEICH(A4;$Z$4:$Z$13;0);(C4="T")*1+(C4="S")*2))
Gruß
Uwe
(:o)
AW: Kombination aus Datum und Schicht Wert finden
13.06.2011 15:08:11
Karl
Hallo Uwe
besten Dank, Werte werden genau so ausgegeben.Viel Formel in kurzer Zeit.
Kannst du mir hierzu noch eine kurze Erklärung geben
(C4="T")*1 warum *1
(C4="S")*2 und hier *2
Gruß
Karl
AW: Kombination aus Datum und Schicht Wert finden
13.06.2011 15:11:04
Karl
Nochmal ich
ich vermute das *1 oder *2 steht für die Spalte wo gesucht werden soll
aber sonst sehe ich immer ein ; und nicht * zb beim Sverweis
Anzeige
AW: Kombination aus Datum und Schicht Wert finden
13.06.2011 15:21:59
Uwe
Hallo Karl,
richtig, der "Term":
(C4="T")*1+(C4="S")*2)
gibt an, in welcher Spalte der Wert steht.
Wenn in C4 z.B. "T" steht, ergibt:
C4="T"
erst einmal:
WAHR
Wenn dort NICHT "T" steht, ergibt es:
FALSCH
Intern ist für Excel aber WAHR=1 und FALSCH=0
Jetzt multipliziere ich das mit 1 und erhalte 1*1=1 oder 1*0=0 für die Spalte.
Bei "S" multipliziere ich 1*2=2 oder 0*2=0 für die Spalte.
Da immer einer der beiden Werte 0 ist, kann ich sie addieren und erhalte 1+0=1 oder 0+2 = 2 für die Spalte.
Ich hoffe ich habe das jetzt nicht zuuu verwirrend dargestellt.
Und soo viel Formel ist das eigentlich gar nicht. Die Kernformel ist ja nur:
INDEX($AA$4:$AB$13;VERGLEICH(A4;$Z$4:$Z$13;0);(C4="T")*1+(C4="S")*2)
Der Rest drumrum ist nur Standard um die Anzeige von #NV zu unterdrücken.
Gruß
Uwe
(:o)
Anzeige
AW: Kombination aus Datum und Schicht Wert finden
13.06.2011 15:25:36
Karl
Dankeschön
Karl

305 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige