Live-Forum - Die aktuellen Beiträge
Datum
Titel
15.07.2024 16:00:57
15.07.2024 15:41:38
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Automatisches Suchen und Eintragen aus Matrix

Automatisches Suchen und Eintragen aus Matrix
Sascha
Einen schönen guten Morgen an alle,
zur automatischen Auswertung von Daten suche ich für folgendes Problem eine Lösung:
Ausgangsdaten (jeder wert in einer Zelle horizontal)
0 1 5 6 8 9
1 2 3 4 7
Dann kommt die Auswertung (Vertikal)
1 2 3 4 5 6 7 8 9
0 1 1 4 0 0 1 0 0 (Hierbei soll excel anhand der nummern automatisch die "0" oder die "1" darunter eintragen)
mein Lösungsansatz war: =index(01;vergleich(XX;XX;0) aber das funktioniert nicht.
Hat jemand von euch eine Lösung hierfür?
Mit freundlichen Grüßen
Sascha

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Automatisches Suchen und Eintragen aus Matrix
29.03.2011 14:01:48
Björn
Hallo Sascha,
erst mal... ich kapier´s nicht :-)
wann soll wie welche Zahl von wo automatisch kommen?
Ich versteh echt nicht, wie du das meinst bzw. was du willst.
Gruß
Björn B.
AW: Automatisches Suchen und Eintragen aus Matrix
29.03.2011 14:25:06
Sascha
hi björn,
ja stimmt, irgenwie bescheuert beschrieben :)...
vielleicht so etwas deutlicher...
a 1 2 5 7
b 2 3 4 6 8
1 2 3 4 5 6 7 8
a a b b a b a b
also excel soll unter die jeweilige zahl den buchstaben schreiben, je nach dem ob die zahl oben hinter dem a oder dem b steht...
Gruß
Sascha
AW: Automatisches Suchen und Eintragen aus Matrix
29.03.2011 14:42:26
Björn
Hallo,
ok, jetzt sieht es besser aus.
Mit der Formel klappt es, kann man bestimmt noch vereinfachen, aber mir reicht es, wenn es funktioniert, aber die Minimalisten dürfen gerne ihren Senf dazugeben ;-)
=WENN(ISTNV(VERGLEICH(A5;$B$1:$J$1;0));WENN(ISTNV(VERGLEICH(A5;$B$2:$J$2;0));"nix";$A$2);$A$1)
In A5 Steht in dem Fall die 1 Deiner Auswertung und die Formel muss dann in A6.
Die Bereiche musst Du natürlich anpassen. A1 und A2 sind das a und das b aus Deiner ersten Reihe.
Diese Formel prüft auch, ob der Suchbegriff überhaupt in einer der beiden Zeilen (a oder b) vorkommt.
Wenn das nicht geprüft werden muss, kann man die 2. Wenn Formel weglassen. Würde ich aber drin lassen.
Gruß
Björn B.
Anzeige

311 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige