Das Archiv des Excel-Forums

addieren mit zwei bedingungen

Bild

Betrifft: addieren mit zwei bedingungen
von: commander

Geschrieben am: 02.10.2003 12:15:54

Hallo Leute!
Ich bin leider nicht so firm in Excel und hoffe, daß ihr mir eine geeignet Formel für folgendes Problem liefern könnt. Ich versuche eine Umsatzstatistik zu führen und habe in Spalte A die Daten der verschiedenen Umsätze aus verschiedenen Jahren. Nun will ich beispielsweise nur Umsätze (Spalte B) addieren, die das Jahr 2003 betreffen. Also größer gleich 01.01.2003 und kleiner 01.01.2004!Ich habe es schon mit summewenn versucht, aber ich bekomme es nicht gebacken. Ich will vermeiden eine Hilfsspalte einzuführen, mit dieser Spalte wäre es kein Problem. Excel soll es aber sofort ausrechnen!

Zur Veranschaulichung:

Spalte A Spalte B
01.02.2002 2500 €
01.03.2003 4000 €
25.08.2001 500 €
01.06.2003 6000 €
22.09.2000 650 €
04.04.2003 1000 €

Umsatz 2003: 11000 €

Die von mir bisher angewandte Formel summewenn liefert den Wert null. Kann mir jemand helfen??
Danke und Gruß
Commander
Bild


Betrifft: Addieren mit zwei Bedingungen
von: Boris
Geschrieben am: 02.10.2003 12:21:57

Hi,

mit SUMMEWENN geht es so:
=SUMME(SUMMEWENN(A:A;{">31.12.2002".">31.12.2003"};B:B)*{1.-1})

Dann kannst du die Kriterien allerdings nicht dynamisch halten.
Dafür wäre dann SUMMENPRODUKT besser:

=SUMMENPRODUKT((JAHR(A1:A100)=2003)*B1:B100)

wobei du für 2003 auch den Bezug auf eine separate Zelle angeben kannst, in der das gewünschte Jahr steht.

Grüße Boris


Bild


Betrifft: AW: addieren mit zwei bedingungen
von: Hajo_Zi
Geschrieben am: 02.10.2003 12:23:59

Hallo ????

ist Dir schon mal aufgefallen das die meisten hier min. einen Vornamen schreiben.

Tabelle2
 AB
101.02.20022500
201.03.20034000
325.08.2001500
401.06.20036000
522.09.2000650
604.04.20031000
7 11000
Formeln der Tabelle
B7 : =SUMMENPRODUKT((JAHR(A1:A6)=2003)*(B1:B6))
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Falls Code vorhanden wurde dieser getestet unter Betriebssystem XP Pro und Excel Version XP SBE.
Bitte kein Mail, Probleme sollen im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.

http://home.media-n.de/ziplies/

 Bild

Excel-Beispiele zum Thema " addieren mit zwei bedingungen"

Eingaben aufaddieren download Wenn "fett", dann addieren download
Alle Werte eines Wochentages aus Monatsblättern addieren download Monatstage eines vorgegebenen Zeitraum listen und addieren download
In einer UserForm Berechnungen aufaddieren download Ausgewählte Werte aus UserForm-ListBoxes addieren download
Werte in Zellen mit vorgegebener Hintergrundfarbe addieren download Werte eines bestimmten Wochentages und eines Zeitbereiches addieren download
Nur sichtbare Zellen addieren download Daten übertragen oder addieren download
Zelleinträge den Werten in einer zweiten Zelle hinzuaddieren download Zellwerte UserForm-TextBoxwerte hinzuaddieren download
In Monatsblättern gelistete Werte nach Produkten addieren download Stunden tagesweise addieren download
Eingabebegrenzung beim Addieren download Artikel bei Nichtvorhandensein eintragen, sonst addieren download
Gemäss Gültigkeits-Listenauswahl Beträge addieren download Wert aus Spalte C, wenn Spalten A und B Bedingungen erfüllen download
Beim Erfüllen einer Bedingungen Farbe für 1 Minute download Anzahl von Werten nach verschiedenen Bedingungen. download
Zeilen zählen, in denen zwei Bedingungen zutreffen download Dem Zellkontextmenü ein Menü "Zahlungsbedingungen" hinzufügen download
Zelle markieren, wenn zwei Bedingungen erfüllt sind download