Microsoft Excel

Herbers Excel/VBA-Archiv

Zahl suchen mit zwei Bedingungen

Betrifft: Zahl suchen mit zwei Bedingungen von: erichm
Geschrieben am: 26.10.2014 08:54:50

Hallo,

in folgender Tabelle soll die Zeile 3 (Spalten E bis K) mit einer Positionszahl nach folgender Anforderung befüllt werden (1. Beispiel):
1. Suche die Zahl aus der E2 in A7 bis A13; gehe dann nach rechts und suche die Suchzahl aus E1 und gib als Ergebnis die Zahl der Position in B5 bis U5 in der Zelle E3 aus.
2. Suche die Zahl aus der F2 in A7 bis A13; gehe dann nach rechts und suche die Suchzahl aus F1 und gib als Ergebnis die Zahl der Position in B5 bis U5 in der Zelle F3 aus.
...usw.

Vorstellung (2)

 ABCDEFGHIJKLMNOPQRSTU
1Suchzahl   101114116119123132133          
2Rückstand   501503503505500504506          
3Position   85171311118          
4                     
5Position1234567891011121314151617181920
6Rückstand                    
7500132138137144108115125143109104123103107118149120146119122102
8501138106133149103147125101118119132112141137142148102110114117
9502142141125109111126143106116138127132130131135136107102103117
10503122127126138114102134144104135103142131148149106116120143129
11504132131125143135149122107139102106130142105112146101103104118
12505143107124106140131136147104114134109119126127138110128133144
13506127148131103129105108143109122130135107134112113116133139140


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

DANKE!
mfg

  

Betrifft: mit INDEX() und 2x VERGLEICH() von: neopa C (paneo)
Geschrieben am: 26.10.2014 09:22:37

Hallo Erich,

.. so:

=INDEX(5:13;VERGLEICH(E2;$A:$A;)-4;VERGLEICH(E3;5:5;)) un Formel nach rechts kopieren.

Gruß Werner
.. , - ...


  

Betrifft: AW: mit INDEX() und 2x VERGLEICH() von: Luschi
Geschrieben am: 26.10.2014 09:44:08

Guten Morgen Werner,

ich hatte die Aufgabe so verstanden, das die Zellen von E3 bis U3 berechnet werden sollen (...und gib als Ergebnis die Zahl der Position in B5 bis U5 in der Zelle E3 aus).
In welche Zelle soll denn Deine Formel rein?

fragt sich Luschi
aus klein-Paris

PS: für Zelle E3 ergibt das natürlich 1 Zirkelbezug



  

Betrifft: Du hast das falsch gelesen von: WF
Geschrieben am: 26.10.2014 09:44:08

.


  

Betrifft: wohl wahr ... trotzdem INDEX() und VERGLEICH() .. von: neopa C (paneo)
Geschrieben am: 26.10.2014 10:07:30

Hallo WF,

... hab jetzt wieder meine Brille aufgesetzt und würde nun für E3 ...was wohl ;-)
trotzdem als eine alternative Variante INDEX() und VERGLEICH() vorschlagen:
=INDEX(5:5;VERGLEICH(E1;INDEX($A:$A;VERGLEICH(E2;$A:$A;)):INDEX($U:$U;VERGLEICH(E2;$A:$A;));))

Gruß Werner
.. , - ...


  

Betrifft: wobei dazu angemerkt werden muss ... von: neopa C (paneo)
Geschrieben am: 26.10.2014 10:12:26

Hallo,

... das vorgenannte Formel die allgemeine Formel wäre, wo in Zeile 5 auch andere Werte stehen können. Wenn wirklich nur die momentan ausgewiesene Zählnummern kann man sich einen INDEX() einsparen.
Dann reicht =VERGLEICH(E1;INDEX($B:$B;VERGLEICH(E2;$A:$A;)):INDEX($U:$U;VERGLEICH(E2;$A:$A;));)

Gruß Werner
.. , - ...




  

Betrifft: AW: wobei dazu angemerkt werden muss ... von: erichm
Geschrieben am: 26.10.2014 10:23:13

DANKE, das funktioniert!


  

Betrifft: die Formel von WF funktioniert auch ... von: neopa C (paneo)
Geschrieben am: 26.10.2014 10:34:36

Hallo Erich,

... ich nutze nur anstelle INDIREKT() fast immer INDEX(), wo immer es möglich und sinnvoll ist (in einigen Fällen ist dies nicht möglich), auch wenn die Formel wie in diesem Fall länger wird, weil die Funktion INDEX() in den meisten Fällen flexibler auf Strukturänderungen reagieren kann und weil sie nicht volatil ist (mehr dazu sieh mal hier: http://www.online-excel.de/excel/singsel.php?f=170

Gruß Werner
.. , - ...


  

Betrifft: Sieht er INDIREKT, wird er zum Tier. von: WF
Geschrieben am: 26.10.2014 10:51:00

:-)
WF


  

Betrifft: AW: Zahl suchen mit zwei Bedingungen von: Luschi
Geschrieben am: 26.10.2014 09:31:12

Hallo erichm,

hab da mal Fragen dazu:
- kann sich die Suchmatrix 'A7:U13' verändern oder ist die starr?
- was soll passieren, wenn nichts gefunden wird?
- kann das auch eine Vba-Lösung sein?
- sind das immer nur positive Zahlen?
- sind alle angezeigte Zahlen echte 'Ganze Zahlen' oder durch Formatierung gerundet?
- stecken hinter den Zahlen irgendwelche Formeln?
- werden die Zahlen eventuell aus einem Fremdsystem importiert?

fragt sich Luschi
aus klein-Paris?

Zusatzfrage: Warum mit Excel-Jeanie eine Grafik anzeigen, gibt es dafür auch eine richtige Excel-Tabelle?


  

Betrifft: AW: Zahl suchen mit zwei Bedingungen von: erichm
Geschrieben am: 26.10.2014 10:22:04

meine Antworten zu den Fragen:

- kann sich die Suchmatrix 'A7:U13' verändern oder ist die starr? = kann sich nach rechts und unten erweitern
- was soll passieren, wenn nichts gefunden wird? = es ist sichergestellt, dass immer was gefunden wird
- kann das auch eine Vba-Lösung sein? = NEIN
- sind das immer nur positive Zahlen? = JA
- sind alle angezeigte Zahlen echte 'Ganze Zahlen' oder durch Formatierung gerundet? = echte ganze Zahlen, nichts gerundet
- stecken hinter den Zahlen irgendwelche Formeln? = teilweise Formeln
- werden die Zahlen eventuell aus einem Fremdsystem importiert? = nein; evtl. muss ich künftig z.T. auf eine andere Tabelle innerhald der Datei zugreifen

fragt sich Luschi
aus klein-Paris?

Zusatzfrage: Warum mit Excel-Jeanie eine Grafik anzeigen, gibt es dafür auch eine richtige Excel-Tabelle? = JA, aber zum upload nicht geeignet, da zu groß


  

Betrifft: mit INDIREKT + 3 mal VERGLEICH von: WF
Geschrieben am: 26.10.2014 09:43:06

Hi,

in E3:
=VERGLEICH(E1;INDIREKT(VERGLEICH(E2;$A:$A;0)&":"&VERGLEICH(E2;$A:$A;0));0)-1
und nach rechts kopieren

Salut WF


  

Betrifft: AW: mit INDIREKT + 3 mal VERGLEICH von: Luschi
Geschrieben am: 26.10.2014 09:53:13

Hallo WF

danke, habe gerade meine xlsm-Datei wieder in eine xlsx-Datei zurückgespeichert.

Gruß von Luschi
aus klein-Paris


 

Beiträge aus den Excel-Beispielen zum Thema "Zahl suchen mit zwei Bedingungen"